summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libelf/libelf_0.8.13.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libelf/libelf_0.8.13.bb b/recipes/libelf/libelf_0.8.13.bb
new file mode 100644
index 0000000000..8d3a57149a
--- /dev/null
+++ b/recipes/libelf/libelf_0.8.13.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "libelf is an ELF object file access library. \
+The elf library provides routines to access, and manipulate, Elf object files."
+LICENSE = "LGPL"
+SECTION = "libs"
+PR = "r0"
+
+SRC_URI = "http://www.mr511.de/software/libelf-${PV}.tar.gz;name=archive \
+ "
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_configure_prepend () {
+ if test ! -e acinclude.m4; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
+ 'libdir=${D}${libdir}' 'includedir=${D}${includedir}' \
+ install
+ for i in libelf.h nlist.h gelf.h sys_elf.h; do
+ install -m 0644 lib/$i ${STAGING_INCDIR}/libelf/
+ done
+ make includedir=${STAGING_INCDIR} install-compat
+}
+
+# both SRC_URI items are the same file
+SRC_URI[archive.md5sum] = "4136d7b4c04df68b686570afa26988ac"
+SRC_URI[archive.sha256sum] = "591a9b4ec81c1f2042a97aa60564e0cb79d041c52faa7416acb38bc95bd2c76d"
+