summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/esc/esc-node-demo_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/esc/esc-node-demo_git.bb b/recipes/esc/esc-node-demo_git.bb
new file mode 100644
index 0000000000..814771b53b
--- /dev/null
+++ b/recipes/esc/esc-node-demo_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Demo of Node.js as a Matrix backend"
+HOMEPAGE = "http://wiki.github.com/jadonk/node/"
+SECTION = "devel"
+PRIORITY = "optional"
+
+PV = "0"
+PR = "r3"
+
+SRC_URI = "git://gist.github.com/397547.git;protocol=git \
+"
+
+SRCREV = "b23123982341cc097e3ecee67a0a299e6017db99"
+S = "${WORKDIR}/git"
+
+DEMO_FILES = " \
+ matrix_command_shell.js \
+ hello_world.js \
+"
+
+do_install() {
+ install -d ${D}${datadir}/esc-training
+ for i in ${DEMO_FILES}; do
+ install -m 0755 ${S}/${i} ${D}${datadir}/esc-training
+ done
+}
+
+RDEPENDS_${PN} = "nodejs"
+FILES_${PN} += "${datadir}/esc-training"
+