summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/rpm/rpm_4.4.2.3.bb2
-rw-r--r--recipes/yum/files/paths2.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/rpm/rpm_4.4.2.3.bb b/recipes/rpm/rpm_4.4.2.3.bb
index 6c2dc55e69..cb8bdd647a 100644
--- a/recipes/rpm/rpm_4.4.2.3.bb
+++ b/recipes/rpm/rpm_4.4.2.3.bb
@@ -30,7 +30,7 @@ EXTRA_OECONF = "--with-python \
--without-efence"
PACKAGES += "python-rpm"
-FILES_python-rpm = "${libdir}/python*/site-recipes/rpm/_*"
+FILES_python-rpm = "${libdir}/python*/site-packages/rpm/_*"
# Handle the db MUTEX settings here, the POSIX library is
# the default - "POSIX/pthreads/library".
diff --git a/recipes/yum/files/paths2.patch b/recipes/yum/files/paths2.patch
index db614dfbbd..2e11bdc71e 100644
--- a/recipes/yum/files/paths2.patch
+++ b/recipes/yum/files/paths2.patch
@@ -13,7 +13,7 @@
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
+PYSYSDIR = $(prefix)
PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
echo "Nothing to do"
@@ -27,7 +27,7 @@
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
+PYSYSDIR = $(prefix)
PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
- PKGDIR = $(PYLIBDIR)/site-recipes/$(PACKAGE)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
echo "Nothing to do"