summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libsdl/libsdl-mixer/fix-flac-madness.diff28
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb8
2 files changed, 34 insertions, 2 deletions
diff --git a/recipes/libsdl/libsdl-mixer/fix-flac-madness.diff b/recipes/libsdl/libsdl-mixer/fix-flac-madness.diff
new file mode 100644
index 0000000000..48fe88ef4a
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer/fix-flac-madness.diff
@@ -0,0 +1,28 @@
+--- /tmp/configure.in 2009-12-02 16:18:33.000000000 +0100
++++ SDL_mixer-1.2.11/configure.in 2009-12-02 16:20:02.000000000 +0100
+@@ -413,24 +413,7 @@
+ [], [enable_music_flac_shared=yes])
+ if test x$enable_music_flac = xyes; then
+ AC_CHECK_HEADER([FLAC/export.h], [have_flac_export=yes])
+- if test x$have_flac_export = xyes; then
+- LIBS_SAVED="$LIBS"
+- LIBS="-lFLAC"
+- AC_MSG_CHECKING([for libflac so-name version >= $libflac_ver])
+- AC_TRY_RUN([
+-#include "FLAC/export.h"
+-#include "stdio.h"
+-int main( int argc, char *argv[] ) {
+-#if defined(FLAC_API_VERSION_CURRENT) && (FLAC_API_VERSION_CURRENT >= $libflac_ver)
+- return 0;
+-#else
+- return 1;
+-#endif
+-}
+-], have_flac_ver=yes, have_flac_ver=no)
+- LIBS="$LIBS_SAVED"
+- AC_MSG_RESULT($have_flac_ver)
+- fi
++ have_flac_ver=yes
+
+ if test x$have_flac_ver = xyes; then
+ AC_CHECK_HEADER([FLAC/stream_decoder.h], [have_flac_hdr=yes])
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index 5ecd2944a2..ee0ba454ba 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -1,10 +1,14 @@
DESCRIPTION = "Simple DirectMedia Layer mixer library."
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "virtual/libsdl libmikmod libvorbis"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis"
LICENSE = "LGPL"
-SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
+ file://fix-flac-madness.diff;patch=1"
+
S = "${WORKDIR}/SDL_mixer-${PV}"
export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"