aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
Commit message (Collapse)AuthorAgeFilesLines
* gst-rtsp: added recipe for v0.10.7Maksym Parkachov2010-11-064-21/+14
| | | | | | | | * reworked old versions with common .inc file * added version of 0.10.7 Signed-off-by: Maksym Parkachov <lazy.gopher@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mplayer,gst-plugins-ugly: bump PR to rebuild after libdvdread3 -> ↵Martin Jansa2010-10-261-1/+1
| | | | | | libdvdread4 upgrade Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* Various fixes for cp argument portabilityChris Larson2010-10-212-3/+3
|
* gst-plugins-ugly: add 0.10.16Denys Dmytriyenko2010-10-201-0/+20
| | | | Signed-off-by: Denys Dmytriyenko <denis@denix.org>
* gst-plugins-good: add 0.10.25Denys Dmytriyenko2010-10-201-0/+15
| | | | Signed-off-by: Denys Dmytriyenko <denis@denix.org>
* gstreamer: bump PR for introspection changeKoen Kooi2010-10-142-1/+3
|
* gst-plugins: bump PR for cdio commitKoen Kooi2010-10-031-1/+1
|
* gstreamer : moved unused files to obsolete dirFrans Meulenbroeks2010-10-033-79/+0
| | | | Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
* gst-plugins.inc: fix path to orcc when prefix != /usrMichael Smith2010-09-271-1/+3
| | | | Signed-off-by: Michael Smith <msmith@cbnco.com>
* gst-plugins-base 0.10.30: depend on gtk+Michael Smith2010-09-271-1/+1
| | | | | | Some of the tests and examples require gtk. Signed-off-by: Michael Smith <msmith@cbnco.com>
* gst-plugins: add some more missing dependsKoen Kooi2010-09-231-2/+2
| | | | * spotted by the angstrom testlab: http://gitorious.org/angstrom/angstrom-testlab/commit/a87e64ae3fbe47b679712c5c873f21e56f325c8f
* gst-plugins-bad: add 0.10.20Koen Kooi2010-09-231-0/+11
|
* gst-plugin-gles: bump SRCREVKoen Kooi2010-09-221-9/+11
|
* gst-plugins-base: add 0.10.30Koen Kooi2010-09-221-0/+27
|
* gstreamer: add 0.10.30Koen Kooi2010-09-221-0/+11
|
* gst-plugins-base_0.10.29: Fix the gtk-doc Makefiles for make 3.82Holger Hans Peter Freyther2010-09-182-1/+27
| | | | | This is patching common/ so the patch applies to all gstreamer plugins using the same version of common.
* gst-plugins-bad_0.10.19.bb: add libmodplug to DEPENDS.Graham Gower2010-09-011-2/+2
| | | | | | | | Several images want gst-plugin-modplug (e.g. illume-image and the fso images). They fail to find it without this. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
* recipes: bump PR in recipes depending on openssl after SHR and Angstrom ↵Martin Jansa2010-08-161-1/+1
| | | | | | moved to openssl-1.0.0 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: bump PR for packages depending on jpeg which changed .so name with ↵Martin Jansa2010-08-083-2/+4
| | | | | | | 6b -> 8b upgrade * distro maintainers: please consider upgrading jpeg first to bump PR just once * this list is incomplete for sure, only recipes-versions I had built in my tmpdir, feel free to add more
* gst-ffmpeg: use immediate var expansion of TOOLCHAIN_PATH for PATH_prependDenys Dmytriyenko2010-08-056-8/+6
| | | | | | Fixes the recursive var expansion when TOOLCHAIN_PATH is derived from PATH. Signed-off-by: Denys Dmytriyenko <denis@denix.org>
* recipes: Fix the PATHs for toolchains.Khem Raj2010-08-036-6/+6
| | | | | | | | * Look into the new multi-machine friendly installation. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
* ffmpeg_svn.bb: bump SRCREV to make it build on armv4t againKlaus Kurzmann2010-07-302-1/+3
| | | | | | and bump PR of recipes that depend on it Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
* recipes: Fix references to CROSS_DIRKhem Raj2010-07-226-6/+6
| | | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com> Acked-by: Richard Purdie <rpurdie@rpsys.net> Ackef-by: Chris Larson <clarson@kergoth.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@openembedded.org>
* gst-plugins-bad 0.10.19: add missing dep on libcdaudioKoen Kooi2010-07-211-1/+1
|
* gst-musicxml2midi: add git versionKoen Kooi2010-07-081-0/+19
|
* gst-ffmpeg: add 0.10.10, bump PR for 0.10.8Koen Kooi2010-06-232-4/+6
|
* recipes: bump PR/INC_PR for packages changed in ↵Martin Jansa2010-06-101-1/+1
| | | | | | | | | | | | | | RDEPENDS/RRECOMMENDS/RSUGGESTS/RPROVIDES/RCONFLICTS/RREPLACES cleanup * only 769 from 1102 recipes were covered by automatic PR bump, list of remaining 333 recipes not using PR/INC_PR is available for manual PR add or INC_PR conversion - volunteers? http://build.shr-project.org/tests/jama/files.not.PR.bumped * just echo 'PR = "r1"' to recipes without any PR/INC_PR is not so good idea without manual check, because sometimes they rely on PR set in their .inc file and "r1" could make it go backwards Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gstreamer_0.10.28.bb: Fix to build with gettext 0.18Khem Raj2010-06-052-0/+1017
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDSMartin Jansa2010-06-031-1/+1
| | | | | | | | | | | | | | | | | | | | * there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
* gst-plugins-ugly: add 0.10.15Koen Kooi2010-06-011-0/+20
|
* gst-plugins-bad: add 0.10.19Koen Kooi2010-06-011-0/+11
|
* gst-plugins-good: add 0.10.23Koen Kooi2010-06-011-0/+13
|
* gst-plugins-base: add 0.10.29Koen Kooi2010-06-011-0/+26
|
* gst-plugins: dependency tweaks, enable more pluginsKoen Kooi2010-06-011-2/+2
|
* gstreamer: add 0.10.29Koen Kooi2010-06-011-0/+11
|
* Make the do_patch apply=yes param implicit if extension is .diff/.patchChris Larson2010-05-2523-34/+34
| | | | | | | | For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
* Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>Chris Larson2010-05-2523-34/+34
| | | | | | | | I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
* gst-plugins: enable gst-plugin-x264Koen Kooi2010-05-141-2/+2
|
* gst-plugins: build some more plugins (e.g. mms, aacparse, faad)Koen Kooi2010-05-061-2/+2
|
* gst-plugins-ugly-sid: add checksumsMartin Jansa2010-04-131-0/+3
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: move checksums to recipes from checksums.ini, part 2 manual adjustementMartin Jansa2010-04-122-0/+6
| | | | | | | | | | | | | | | | | | * all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: move checksums to recipes from checksums.iniMartin Jansa2010-04-1227-0/+81
| | | | | | | * fetch all *.bb with patched utils.bbclass appending all checksums found only in checksums.ini to recipe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gst-meta-base: fixed ivorbis dependency and bump PRDenis 'GNUtoo' Carikli2010-04-031-2/+2
| | | | | | | | | I had the following error: | Collected errors: | * satisfy_dependencies_for: Cannot satisfy the following dependencies for gst-meta-audio: | * gst-plugin-ivorbis * but... I also had that in my deploy dir: gst-plugin-ivorbisdec_0.10.28-r7.1.5_armv6.ipk So I changed gst-plugin-ivorbis to gst-plugin-ivorbisdec
* gst-plugins-bad 0.10.18 : also depend on orc and bump PRDenis 'GNUtoo' Carikli2010-04-031-1/+3
| | | | | | | | | | | | | | | | | | | | If we depend only on orc-native and not also on orc (and orc is not installed): *it won't be able to find orc/orc.h *orcc will be detected correctly,which will cause the following code: " do_configure_append() { for i in $(find ${S} -name "Makefile") ; do sed -i -e s:/usr/bin/orcc:${STAGING_BINDIR_NATIVE}/orcc:g $i done } " that is in gst-plugins.inc to sed the /usr/bin/orcc in STAGING_BINDIR_NATIVE}/orcc with STAGING_BINDIR_NATIVE}/orcc roughly a path like: ${TMPDIR}/staging/i686-linux/usr/bin/orcc will result in ${TMPDIR}/staging/i686-linux/${TMPDIR}/staging/i686-linux/usr/bin/orcc:
* gst-plugins-base_0.10.28: add updated ivorbis-thumb patch from ↵Martin Jansa2010-03-182-1/+14
| | | | | | gst-plugins-bad for build fix with thumb enabled Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gstreamer: updatesKoen Kooi2010-03-179-10/+98
| | | | | | | * switch to new-style staging * add support for new-style checksums * move plugins to newer versions, so plugins moved (e.g. ivorbis) * fixup gstconfig header parsing
* gst-ffmpeg: add 0.10.10, needed for newer ffmpeg_svn.bbKoen Kooi2010-03-171-0/+28
|
* gst-plugin-bc: update patch to the version thats going upstreamKoen Kooi2010-03-081-2/+2
|
* gst-plugin-gles: use proper gst-plugin packagingKoen Kooi2010-03-081-14/+6
|
* gst-plugin-bc: add git versionKoen Kooi2010-03-082-0/+50
|