aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/python
Commit message (Collapse)AuthorAgeFilesLines
* python: moved unused files to obsolete dirFrans Meulenbroeks2010-09-273-0/+44
| | | | Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
* python: move 2.6.[124] to obsolete, move all distributions to 2.6.5Martin Jansa2010-08-1729-0/+1677
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
* recipes: bump PR/INC_PR for packages changed in ↵Martin Jansa2010-06-102-2/+2
| | | | | | | | | | | | | | RDEPENDS/RRECOMMENDS/RSUGGESTS/RPROVIDES/RCONFLICTS/RREPLACES cleanup * only 769 from 1102 recipes were covered by automatic PR bump, list of remaining 333 recipes not using PR/INC_PR is available for manual PR add or INC_PR conversion - volunteers? http://build.shr-project.org/tests/jama/files.not.PR.bumped * just echo 'PR = "r1"' to recipes without any PR/INC_PR is not so good idea without manual check, because sometimes they rely on PR set in their .inc file and "r1" could make it go backwards Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDSMartin Jansa2010-06-033-3/+3
| | | | | | | | | | | | | | | | | | | | * there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
* obsolete: add python-efl.incMartin Jansa2010-04-121-0/+38
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* efl: move epsilon/etk to obsolete, because they're not supported with newer ↵Martin Jansa2010-03-192-0/+19
ecore anymore Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>