aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pam/libpam-base-files.bb
Commit message (Collapse)AuthorAgeFilesLines
* libpam-base-files: cups installs its own pam file, so remove it from hereKoen Kooi2010-07-081-1/+1
|
* recipes: bump PR/INC_PR for packages changed in ↵Martin Jansa2010-06-101-1/+1
| | | | | | | | | | | | | | RDEPENDS/RRECOMMENDS/RSUGGESTS/RPROVIDES/RCONFLICTS/RREPLACES cleanup * only 769 from 1102 recipes were covered by automatic PR bump, list of remaining 333 recipes not using PR/INC_PR is available for manual PR add or INC_PR conversion - volunteers? http://build.shr-project.org/tests/jama/files.not.PR.bumped * just echo 'PR = "r1"' to recipes without any PR/INC_PR is not so good idea without manual check, because sometimes they rely on PR set in their .inc file and "r1" could make it go backwards Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDSMartin Jansa2010-06-031-2/+2
| | | | | | | | | | | | | | | | | | | | * there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
* libpam-base-files: bump PRKoen Kooi2010-02-171-1/+1
|
* libpam-base-files: remove polkit-1 that is already in policykit package:Koen Kooi2010-02-171-1/+1
| | | | | | Collected errors: * Package libpam-base-files wants to install file /etc/pam.d/polkit-1 But that file is already provided by package * policykit
* libpam-base-files: RRECOMMEND libpam-metaKoen Kooi2010-01-131-1/+2
|
* libpam-base-files: polkit is provided by policykit itselfKoen Kooi2009-11-251-1/+1
|
* libpam-base-files: Start to add default config files for libpamDavid-John Willis2009-11-241-0/+18
* This will start to get Linux-PAM into a usable state. Default config files derived from Debian with tweaks. Some are not needed and will be dropped later and some should really be packaged elsewhere. * Also update libpam_1.0.2 to depend on this package and the meta package with auth systems as it is not a lot of use without them (it works but can't do anything). * Add 1.1.0 and tweaks to 1.0.2. * Update all the pam.d base config files to support the suggested upstream layout not patches legacy layouts used but some Linux distros. * Use the proper include layouts * Still package some 'suggested' files for common services that do not pack there own pam.d files (TODO: move these to the package recipies not this one).