aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-02-21 22:48:16 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-02-23 00:47:52 +0000
commitc97784d7d822e6ed99274ad91ef0d07840bcbbba (patch)
tree8ec05b4df85860b60f3c094b15d303459909ec35 /recipes-kernel
parentafd960cd366e717f1fa943116e88cef8c62fa241 (diff)
downloadmeta-handheld-c97784d7d822e6ed99274ad91ef0d07840bcbbba.tar.gz
remove linux-kexecboot_3.1, now in meta-initramfs
* add .bbappend * bump PR and INC_PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-kexecboot_3.1.bb7
-rw-r--r--recipes-kernel/linux/linux-kexecboot_3.1.bbappend36
2 files changed, 36 insertions, 7 deletions
diff --git a/recipes-kernel/linux/linux-kexecboot_3.1.bb b/recipes-kernel/linux/linux-kexecboot_3.1.bb
deleted file mode 100644
index 28dc370..0000000
--- a/recipes-kernel/linux/linux-kexecboot_3.1.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require linux-kexecboot.inc
-require linux-${PV}.inc
-
-PR = "${INC_PR}.7"
-S = "${WORKDIR}/linux-${PV}"
-
-COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
diff --git a/recipes-kernel/linux/linux-kexecboot_3.1.bbappend b/recipes-kernel/linux/linux-kexecboot_3.1.bbappend
new file mode 100644
index 0000000..74d63bb
--- /dev/null
+++ b/recipes-kernel/linux/linux-kexecboot_3.1.bbappend
@@ -0,0 +1,36 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-kexecboot-${PV}:${THISDIR}/files:"
+
+COMPATIBLE_MACHINE = "(akita|c7x0|collie|poodle|tosa|spitz)"
+
+# Note we set loglevel=3 and master console on serial to protect bootlogo.
+CMDLINE_c7x0 = "console=tty1 console=ttyS0,115200n8"
+CMDLINE_tosa = "console=tty1 console=ttyS0,115200n8"
+CMDLINE_poodle = "console=tty1 console=ttyS0,115200n8 fbcon=rotate:1"
+CMDLINE_akita = "console=tty1 console=ttyS0,115200n8 fbcon=rotate:1"
+CMDLINE_collie = "console=tty1 console=ttySA0,115200n8 fbcon=rotate:1 mem=64M"
+CMDLINE_spitz = "console=tty1 console=ttyS0,115200n8 fbcon=rotate:1"
+
+# Zaurus machines need kernel size-check.
+KERNEL_IMAGE_MAXSIZE_akita = "1294336"
+KERNEL_IMAGE_MAXSIZE_c7x0 = "1294336"
+KERNEL_IMAGE_MAXSIZE_collie = "1048576"
+KERNEL_IMAGE_MAXSIZE_poodle = "1294336"
+KERNEL_IMAGE_MAXSIZE_tosa = "1294336"
+KERNEL_IMAGE_MAXSIZE_spitz = "1294336"
+
+LOGO_SIZE ?= "."
+
+SRC_URI += "file://defconfig \
+ file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 \
+ "
+
+SRC_URI_append_collie = " \
+ file://0001-pcmcia-pxa2xx_sharpsl-retain-ops-structure-on-collie.patch \
+ file://locomo_kbd_tweak-r2.patch \
+ "
+
+SRC_URI_append_poodle = " \
+ file://locomo_kbd_tweak-r2.patch \
+ "
+
+