aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-08-19 13:05:59 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:02 +0200
commit26ef409d0899a9ca1d2b71cc7a1d78ff1feeea7e (patch)
treeeefd590e49feb9ec5622aa0b13643e03d5a75368
parenta7f02b1fe59e1c35e0abfe5f716df0fcd8b9d204 (diff)
downloadmeta-openembedded-contrib-26ef409d0899a9ca1d2b71cc7a1d78ff1feeea7e.tar.gz
python*-ptyprocess: add v0.5.2
The python2 version was dropped from oe-core. Also add support for python3. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-ptyprocess.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-ptyprocess_0.5.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess_0.5.2.bb2
3 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-ptyprocess.inc b/meta-python/recipes-devtools/python/python-ptyprocess.inc
new file mode 100644
index 0000000000..43f2d094ac
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ptyprocess.inc
@@ -0,0 +1,20 @@
+SUMMARY = "Run a subprocess in a pseudo terminal"
+HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
+
+SRCNAME = "ptyprocess"
+
+SRC_URI[md5sum] = "d3b8febae1b8c53b054bd818d0bb8665"
+SRC_URI[sha256sum] = "e64193f0047ad603b71f202332ab5527c5e52aa7c8b609704fc28c0dc20c4365"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-ptyprocess_0.5.2.bb b/meta-python/recipes-devtools/python/python-ptyprocess_0.5.2.bb
new file mode 100644
index 0000000000..7ca4587714
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ptyprocess_0.5.2.bb
@@ -0,0 +1,2 @@
+require python-ptyprocess.inc
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess_0.5.2.bb b/meta-python/recipes-devtools/python/python3-ptyprocess_0.5.2.bb
new file mode 100644
index 0000000000..bdcd0e2539
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess_0.5.2.bb
@@ -0,0 +1,2 @@
+require python-ptyprocess.inc
+inherit pypi setuptools3