aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-07-19 09:22:32 +0200
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commit892622420d10f164bb6a4c82b7d5abad7f042863 (patch)
tree80e5a85ed73a44636d71ddc476b29eda095eadc7
parent1507fa0aa295c6b547fc280578b1e7e6b4f9f7a6 (diff)
downloadmeta-openembedded-contrib-892622420d10f164bb6a4c82b7d5abad7f042863.tar.gz
cppzmq: use cmake to install the package
This way also the required cmake configs are installed so other packages can find it. It seems also cleaner to use the upstream mechanism than to have our own install script. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/zeromq/cppzmq_git.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta-oe/recipes-connectivity/zeromq/cppzmq_git.bb b/meta-oe/recipes-connectivity/zeromq/cppzmq_git.bb
index 4920bce8c8..9aff59c6ce 100644
--- a/meta-oe/recipes-connectivity/zeromq/cppzmq_git.bb
+++ b/meta-oe/recipes-connectivity/zeromq/cppzmq_git.bb
@@ -11,10 +11,7 @@ SRC_URI = "git://github.com/zeromq/cppzmq.git"
S = "${WORKDIR}/git"
-do_install () {
- install -d ${D}/usr/include
- install -m 0755 ${S}/zmq.hpp ${D}/usr/include/
-}
+inherit cmake
PACKAGES = "${PN}-dev"