aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2017-11-05 22:07:27 +0000
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:34:05 -0800
commitd91f92cf042029f879feb1b9b1e4e84b4905c908 (patch)
tree16e62355995e06f6dbb80127b4c790220ad65a44
parent57492d40b569f0bfbfcf351b363d76f714e41729 (diff)
downloadmeta-openembedded-contrib-d91f92cf042029f879feb1b9b1e4e84b4905c908.tar.gz
mercurial: Support building for target
Rather than trying to work out the exact python modules needed, we just add 'python-modules' to the dependencies list. If you can afford to install mercurial on target then python-modules shouldn't be too much of a burden. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb (renamed from meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb b/meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb
index 693d4e40dd..90524974ba 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_4.4.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial_4.4.bb
@@ -3,7 +3,11 @@ HOMEPAGE = "http://mercurial.selenic.com/"
SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "python-native"
+DEPENDS = "python python-native"
+DEPENDS_class-native = "python-native"
+RDEPENDS_${PN} = "python python-modules"
+
+inherit python-dir
SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
SRC_URI[md5sum] = "c1d9fad1b7ed7077b0d4ae82e71154db"
@@ -11,7 +15,7 @@ SRC_URI[sha256sum] = "234af4a67565c85923b0a1910c704ab44bcf12f69b8553268720877656
S = "${WORKDIR}/mercurial-${PV}"
-inherit native
+BBCLASSEXTEND = "native"
EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
PREFIX=${prefix}"
@@ -24,3 +28,4 @@ do_install () {
oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
}
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"