aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmo Puustinen <ismo.puustinen@intel.com>2017-06-08 12:57:31 +0300
committerArmin Kuster <akuster808@gmail.com>2017-10-19 09:58:30 -0700
commit3031a57bd99007b92b65fd868f96833a15589ae0 (patch)
treeef0f75705cfd980dee9dc2bf6ccd072778dd52e4
parentdfbdd28d206a74bf264c2f7ee0f7b3e5af587796 (diff)
downloadmeta-openembedded-contrib-akuster/pyro-next.tar.gz
opencv: fix runtime dependencies.akuster/pyro-next
The newly split "libopencv-ts" package is empty (and thus not created), because all ts files are installed in the development package. So, do not add a runtime dependency to libopencv-ts. Signed-off-by: Ismo Puustinen <ismo.puustinen@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.2.bb b/meta-oe/recipes-support/opencv/opencv_3.2.bb
index 535c761fa5..fc62e99755 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.2.bb
@@ -126,7 +126,7 @@ python populate_packages_prepend () {
metapkg = pn
d.setVar('ALLOW_EMPTY_' + metapkg, "1")
- blacklist = [ metapkg ]
+ blacklist = [ metapkg, "libopencv-ts" ]
metapkg_rdepends = [ ]
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale') and not pkg.endswith('-staticdev'):