aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-10-12 14:26:31 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:53:21 +0200
commit3c3908a03abb93d901e67ceaedeadc51fdb8eab3 (patch)
tree45664a8b173cb0e01b1072d3e9444dfd94d4f28d
parent7967a79c8352daf8065496ff76ad23c8c5609467 (diff)
downloadmeta-openembedded-contrib-3c3908a03abb93d901e67ceaedeadc51fdb8eab3.tar.gz
efibootmgr: 0.6.0 -> 0.12
Upgrade efibootmgr from 0.6.0 to 0.12. * update HOMEPAGE * drop obsolete patches that source files have been removed * add dependency efivar * update CFLAGS to fix print wrong version issue Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb27
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb26
-rw-r--r--meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch28
-rw-r--r--meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch26
4 files changed, 27 insertions, 80 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
new file mode 100644
index 0000000000..03aaf13a62
--- /dev/null
+++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
+SUMMARY = "EFI Boot Manager"
+HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
+SECTION = "base"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+DEPENDS = "pciutils zlib efivar"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+SRC_URI = "https://github.com/rhinstaller/efibootmgr/releases/download/${BP}/${BP}.tar.bz2 \
+ file://ldflags.patch \
+ "
+
+SRC_URI[md5sum] = "6647f5cd807bc8484135ba74fcbcc39a"
+SRC_URI[sha256sum] = "a66f5850677e86255d93cb1cead04c3c48a823a2b864c579321f2a07f00256e6"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar` \
+ -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR)\" '"
+
+do_install () {
+ install -D -p -m0755 src/efibootmgr/efibootmgr ${D}/${sbindir}/efibootmgr
+}
+
+inherit pkgconfig
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb
deleted file mode 100644
index 501ff2a6e1..0000000000
--- a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.6.0.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
-SUMMARY = "EFI Boot Manager"
-HOMEPAGE = "http://linux.dell.com/efibootmgr/"
-SECTION = "base"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-
-DEPENDS = "pciutils zlib"
-
-COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
-
-SRC_URI = "http://linux.dell.com/efibootmgr/permalink/efibootmgr-${PV}.tar.gz \
- file://ldflags.patch \
- file://docbook-fixes.patch \
- file://w-keep-existing-mbr-signature.patch \
-"
-
-SRC_URI[md5sum] = "9e9a31d79e579644de83a14139b66d10"
-SRC_URI[sha256sum] = "5167488b92950e60028d1025942ce6bda04638c6fb5e110abb8c8f687844d155"
-
-EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/lib -I${S}/src/include -fgnu89-inline'"
-
-do_install () {
- install -D -p -m0755 src/efibootmgr/efibootmgr ${D}/${sbindir}/efibootmgr
-}
diff --git a/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch b/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch
deleted file mode 100644
index f2dc83bbe1..0000000000
--- a/meta-oe/recipes-extended/efibootmgr/files/docbook-fixes.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Upstream-Status: Pending
-
-Import this patch from meta-linaro.
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
-
-diff --git a/src/man/man8/efibootmgr.8.docbook b/src/man/man8/efibootmgr.8.docbook
-index aef4444..eb8f266 100644
---- a/src/man/man8/efibootmgr.8.docbook
-+++ b/src/man/man8/efibootmgr.8.docbook
-@@ -302,7 +302,7 @@
- <title>Displaying the current settings (must be root).</title>
-
- <para>
-- <computeroutput>
-+ <programlisting>
- [root@localhost ~]# efibootmgr
- BootCurrent: 0004
- BootNext: 0003
-@@ -313,7 +313,7 @@
- Boot0002* Hard Drive(Device:80)/HD(Part1,Sig00112233)
- Boot0003* PXE Boot: MAC(00D0B7C15D91)
- Boot0004* Linux
-- </computeroutput>
-+ </programlisting>
- </para>
- <para>This shows:</para>
- <itemizedlist>
diff --git a/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch b/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch
deleted file mode 100644
index 58bd135564..0000000000
--- a/meta-oe/recipes-extended/efibootmgr/files/w-keep-existing-mbr-signature.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Upstream-Status: Pending
-
-Import this patch from meta-linaro.
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
----
-Description: Fix -w option to leave an existing unique MBR signature intact
- This makes the implementation match the documentation.
-Author: Colin Watson <cjwatson@ubuntu.com>
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/1065261
-Forwarded: no
-Last-Update: 2013-02-01
-
-Index: b/src/lib/disk.c
-===================================================================
---- a/src/lib/disk.c
-+++ b/src/lib/disk.c
-@@ -352,7 +352,7 @@
- printf("******************************************************\n\n");
-
- }
-- else if (opts.write_signature) {
-+ else if (!mbr->unique_mbr_signature && opts.write_signature) {
-
- /* MBR Signatures must be unique for the
- EFI Boot Manager