aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-12-31 17:01:09 +0800
committerDaniel McGregor <daniel.mcgregor@vecima.com>2016-04-26 13:28:15 -0600
commit15164270040fed7fbc0ecdb07f2ef04d8f0f572c (patch)
tree765d0fbb13b0c2feb66bd0e5991089dc809e776c
parent1dac861e9d0c8601dd552dc149b400a3877c35fc (diff)
downloadmeta-openembedded-contrib-15164270040fed7fbc0ecdb07f2ef04d8f0f572c.tar.gz
net-snmp: fix the replacement in net-snmp-config
when net-snmp-config is used to configure by other package, and fail since /libnl3 is not found, in fact, it should be -I/usr/include/libnl3, and is modified as /libnl3 incorrectly. instead of modify the net-snmp-config for target, the one under ${bindir_crossscripts} should be replaced with ${TAGING_INCDIR} Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index 62186d4d0b..83641964ba 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -64,8 +64,7 @@ do_install_append() {
install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/snmpd
install -m 644 ${WORKDIR}/snmpd.conf ${D}${sysconfdir}/snmp/
install -m 644 ${WORKDIR}/snmptrapd.conf ${D}${sysconfdir}/snmp/
- sed -e "s@-I/usr/include@@g" \
- -e "s@^prefix=.*@prefix=${STAGING_DIR_HOST}@g" \
+ sed -e "s@^prefix=.*@prefix=${STAGING_DIR_HOST}@g" \
-e "s@^exec_prefix=.*@exec_prefix=${STAGING_DIR_HOST}@g" \
-e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \
-e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \
@@ -99,6 +98,8 @@ net_snmp_sysroot_preprocess () {
if [ -e ${D}${bindir}/net-snmp-config ]; then
install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
install -m 755 ${D}${bindir}/net-snmp-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ sed -e "s@-I/usr/include@-I${STAGING_INCDIR}@g" \
+ -i ${SYSROOT_DESTDIR}${bindir_crossscripts}/net-snmp-config
fi
}