aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Pijanowski <maciej.pijanowski@3mdeb.com>2019-05-31 14:24:48 +0200
committerKhem Raj <raj.khem@gmail.com>2019-06-15 17:17:09 -0700
commit70c2f87bff1fcd45dc124a10b4c03bc92ab943ab (patch)
treeb5e66803f57f1a56b4a18c35edcfe8500d8c7173
parent0e342ecaa48e43c406df0f3c754b31c12fe56d8b (diff)
downloadmeta-openembedded-contrib-70c2f87bff1fcd45dc124a10b4c03bc92ab943ab.tar.gz
recipes-benchmark/stressapptest_1.0.9.bb: add recipe
This patch introduces recipe for the stressapptest utility. The recipe builds without errors and warnings (tested on thud). It basically uses autootools to buildm so should build just fine on the other releases as well. Basic commands from the project's README were tested on a few armv7 / armv8 platforms. Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb b/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb
new file mode 100644
index 0000000000..3e5748a3a1
--- /dev/null
+++ b/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Stressful Application Test"
+DESCRIPTION = "Stressful Application Test (or stressapptest, its unix name) \
+ is a memory interface test. It tries to maximize randomized traffic to memory \
+ from processor and I/O, with the intent of creating a realistic high load \
+ situation in order to test the existing hardware devices in a computer. \
+"
+HOMEPAGE = "https://github.com/stressapptest/stressapptest"
+SECTION = "benchmark"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=55ea9d559f985fb4834317d8ed6b9e58"
+
+SRC_URI = "https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz"
+
+SRC_URI[md5sum] = "d3a526c174c049dd7a1068dc74a62be2"
+SRC_URI[sha256sum] = "2ba470587ad4f6ae92057d427c3a2a2756e5f10bd25cd91e62eaef55a40b30a1"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools