aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-11-23 14:55:42 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-29 11:04:54 +0100
commit92bf1cf3684ec0c435feafab4694e7820bbd5fe1 (patch)
tree18d6a36f3e32609e7c345dd3917d83b0ae6e31d9
parent6ba5d2f782f9310e48a39146a98da2ed8843f380 (diff)
downloadmeta-openembedded-contrib-92bf1cf3684ec0c435feafab4694e7820bbd5fe1.tar.gz
e-wm: fix file permissions on sysactions.conf
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_svn.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm_svn.bb b/meta-efl/recipes-efl/e17/e-wm_svn.bb
index d5f92bb6a2..abee301a1e 100644
--- a/meta-efl/recipes-efl/e17/e-wm_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=76de290eb3fdda12121830191c152a7d"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r9"
+PR = "r10"
SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives gettext
@@ -32,6 +32,10 @@ do_install_append() {
# customising - should rather make this simple upstream
install -m 755 ${WORKDIR}/enlightenment_start.oe ${D}/${bindir}
+ # security reasons, e-wm checks that in runtime
+ # xinit[418]: ERROR: CONFIGURATION FILE HAS BAD PERMISSIONS
+ chmod 600 ${D}/${sysconfdir}/enlightenment/sysactions.conf
+
install -d ${D}/${datadir}/applications/
install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop
sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop