aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLewis, Nick <nick.lewis@usa.g4s.com>2014-05-23 16:09:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:27:20 +0200
commit1aeeddd4de69dfa31c461e898745cca76eb4727d (patch)
treec0f5fde248f222fd28ec99f3dd890ed71230ebf1
parentff7b1818968f8346d1907f66432e6b1fd34ef96e (diff)
downloadmeta-openembedded-contrib-1aeeddd4de69dfa31c461e898745cca76eb4727d.tar.gz
libxml++: fix build with B noteq S
Signed-off-by: Nick Lewis <nick.lewis@usa.g4s.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
index a18822f724..1e847be7ac 100644
--- a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
@@ -65,9 +65,9 @@ index d9541ca..c28b49c 100644
+ $(MKDIR_P) $(DESTDIR)/examples
+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
-+ cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
++ $(foreach i, $(dist_noinst_DATA), cp --parents $(srcdir)/$(i) $(DESTDIR)/examples;)
+ cp Makefile $(DESTDIR)/examples
+ $(MKDIR_P) $(DESTDIR)/macros
-+ cp ../macros/test-driver $(DESTDIR)/macros
++ cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros
+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
+