aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-02-10 14:55:10 +0800
committerArmin Kuster <akuster808@gmail.com>2015-03-21 07:56:31 -0700
commit66ca394c5b0b597b9eaaa22f8bf9fc924ef9ab54 (patch)
tree7348da84265afccfd622cc09d0f0d4f91a507644
parentfe54ee0ef2521cf39e764f8bdeca76f72395e6b4 (diff)
downloadmeta-openembedded-contrib-66ca394c5b0b597b9eaaa22f8bf9fc924ef9ab54.tar.gz
python-pip: add python-distribute in RDEPENDS
Fix the following runtime issue of pip: # pip Traceback (most recent call last): File "/usr/bin/pip", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pip_1.3.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-pip_1.3.1.bb b/meta-python/recipes-devtools/python/python-pip_1.3.1.bb
index d1a7c8b3ae..1388a3dce2 100644
--- a/meta-python/recipes-devtools/python/python-pip_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python-pip_1.3.1.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/pip-${PV}"
inherit setuptools
# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
-RDEPENDS_${PN} = "python-modules"
+RDEPENDS_${PN} = "python-modules python-distribute"