aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-20 09:07:47 -0700
committerArmin Kuster <akuster808@gmail.com>2021-05-23 08:28:47 -0700
commit0567340210657268e21d6b2ce55fa82291f4a0d5 (patch)
treeac1653870a0ce4ac19a44a31f5992276a8e41aac
parent5aa0e96d7ab3b2734335e6a9ba57a1ee34139d55 (diff)
downloadmeta-openembedded-contrib-0567340210657268e21d6b2ce55fa82291f4a0d5.tar.gz
opencv: Disable tbb on riscv/musl
getcontext|setcontext functionality is provided via libucontext for musl but this library is not yet ported to RISCV Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit a116630318789f08ebc6f350c37ef43f0884cb30) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.5.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
index 1dcd8586cd..226bad5778 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.5.2.bb
@@ -108,6 +108,9 @@ PACKAGECONFIG ??= "gapi python3 eigen jpeg png tiff v4l libv4l gstreamer samples
# TBB does not build for powerpc so disable that package config
PACKAGECONFIG_remove_powerpc = "tbb"
+# tbb now needs getcontect/setcontext which is not there for all arches on musl
+PACKAGECONFIG_remove_libc-musl_riscv64 = "tbb"
+PACKAGECONFIG_remove_libc-musl_riscv32 = "tbb"
PACKAGECONFIG[gapi] = "-DWITH_ADE=ON -Dade_DIR=${STAGING_LIBDIR},-DWITH_ADE=OFF,ade"
PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"