aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoonam Jadhav <poonam.jadhav@kpit.com>2023-11-21 19:01:13 +0530
committerArmin Kuster <akuster808@gmail.com>2023-12-13 13:35:51 -0500
commit01c0aaaf620f9eeb073f39ce5149f08bb6a32cb0 (patch)
tree4acbd6690b9916b2909c407a5b9524537bda0120
parentcdab5037c9dea0eca042010d3b7af984edfc9f79 (diff)
downloadmeta-openembedded-contrib-01c0aaaf620f9eeb073f39ce5149f08bb6a32cb0.tar.gz
sdbus-c++: Update ptest path
Update ptest path to run sdbus-c++ ptest Signed-off-by: Poonam Jadhav <poonam.jadhav@kpit.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
index 76fd6b65b1..6fd826cbbd 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
@@ -39,6 +39,11 @@ do_install:append() {
fi
}
-PTEST_PATH = "${libdir}/${BPN}/tests"
+PTEST_PATH = "${libdir}/${BPN}/ptest"
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${B}/tests/sdbus-c++-unit-tests ${D}${PTEST_PATH}
+}
+
FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/"
FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"