aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-18 18:31:31 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-22 13:18:23 +0100
commit055938e9f7bd7cdba1d5c560eee17f56049953ab (patch)
tree1bf072f2574d36739727a605a4ba4e924e65f79d
parent2942932a8bbc18115d8093a9e32cd85083a70635 (diff)
downloadmeta-openembedded-contrib-055938e9f7bd7cdba1d5c560eee17f56049953ab.tar.gz
lua5.1: Fix multilib install
when we have multilib enabled then there are some hardcoded assumptions in lua code which needs to be fixed some can be fixed by simply passing right variable on cmdline for the one's in sourcecode needs to be edited in place. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb b/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb
index 9da9e957a9..f303d8711d 100644
--- a/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb
+++ b/meta-oe/recipes-devtools/lua/lua5.1_5.1.5.bb
@@ -4,6 +4,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=59bdd99bb82238f238cf5c65c21604fd"
HOMEPAGE = "http://www.lua.org/"
+PR = "r1"
+
DEPENDS += "readline"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
file://bitwise_operators.patch \
@@ -21,6 +23,7 @@ EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLD
do_configure_prepend() {
sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
+ sed -i -e s:lib/lua/5.1/:${base_libdir}/lua/5.1/:g src/luaconf.h
}
do_compile () {
@@ -34,6 +37,8 @@ do_install () {
'INSTALL_INC=${D}${includedir}/' \
'INSTALL_MAN=${D}${mandir}/man1' \
'INSTALL_SHARE=${D}${datadir}/lua' \
+ 'INSTALL_LIB=${D}${libdir}' \
+ 'INSTALL_CMOD=${D}${libdir}/lua/5.1' \
install
install -d ${D}${libdir}/pkgconfig
install -m 0644 ${WORKDIR}/lua5.1.pc ${D}${libdir}/pkgconfig/lua5.1.pc