aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2016-05-06 20:48:54 +0500
committerArmin Kuster <akuster808@gmail.com>2016-05-13 23:02:15 -0700
commit947e7f113cef6db43e13b987d1d47ac68674f629 (patch)
tree43ee7bf9853ffe6a3853f99a7f7883124a2016e5
parentf797b791efdb656704262f9c46b7c9adae911faa (diff)
downloadmeta-openembedded-contrib-947e7f113cef6db43e13b987d1d47ac68674f629.tar.gz
libnice, farsight2: unblacklist as libnice's nice.pc issue fixed.
* Update do_compile_append where it was updating *.pc from ${S} and removing staging dir folder. Now we have seperate build folder where packages get build. We have to search pc in ${B} not in ${S}. After updating the tmp dir path is removed from nice.pc file. * Remove PNBLACKLIST for libnice and farsight2 recipes. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/farsight/farsight2_0.0.22.bb2
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.0.13.bb4
2 files changed, 1 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
index ffb222bd72..2989850e98 100644
--- a/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
+++ b/meta-oe/recipes-support/farsight/farsight2_0.0.22.bb
@@ -28,5 +28,3 @@ FILES_${PN}-dbg += "${libdir}/*/.debug"
SRC_URI[md5sum] = "e1f540cf3ebab06c3d7db1f46b44ac88"
SRC_URI[sha256sum] = "3ae59aa61a8071c9fad111e5fd606aabc27961eb4192f8729987a27dae6b3974"
-
-PNBLACKLIST[farsight2] ?= "Depends on broken libnice"
diff --git a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
index a9081dce5b..620ee1f6cc 100644
--- a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
+++ b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
@@ -28,7 +28,7 @@ do_configure_prepend() {
}
do_compile_append() {
- for i in $(find ${S} -name "*.pc") ; do
+ for i in $(find ${B} -name "*.pc") ; do
sed -i -e s:${STAGING_DIR_TARGET}::g \
-e s:/${TARGET_SYS}::g \
$i
@@ -38,5 +38,3 @@ do_compile_append() {
SRC_URI[md5sum] = "e5b9f799a57cb939ea2658ec35253ab9"
SRC_URI[sha256sum] = "d8dd260c486a470a6052a5323920878a084e44a19df09b15728b85c9e3d6edf0"
-
-PNBLACKLIST[libnice] ?= "BROKEN: QA Issue: nice.pc failed sanity test (tmpdir)"