aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2013-01-18 12:13:32 -0500
committerJoe MacDonald <joe.macdonald@windriver.com>2013-01-24 10:35:49 -0500
commitb7ff6ac09affebe72b7587d7e345adaae427ef3d (patch)
tree3c5f0650d7e21ae48177d262194aca40484c89d0
parentaf502674e6d0dc184215ff02d92938c168118911 (diff)
downloadmeta-openembedded-contrib-b7ff6ac09affebe72b7587d7e345adaae427ef3d.tar.gz
autofs: fails to compile with openldap disabled
As of 5.0.6, it appears that changes were introduced so that if you compile with openldap disabled and openldap headers are not available, then autofs fails to build. Since autofs no longer depends on openldap, remove the dependency. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch42
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb5
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch
new file mode 100644
index 0000000000..31c8510a69
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/fix_disable_ldap.patch
@@ -0,0 +1,42 @@
+autofs: fails to compile with openldap disabled
+
+As of 5.0.6, it appears that changes were introduced so that
+if you compile with openldap disabled and openldap headers are not
+available, then autofs fails to build.
+
+Upstream-Status: Pending
+
+Signed-off-by: Amy Fong <amy.fong@windriver.com>
+--
+ lookup_ldap.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+---
+ include/lookup_ldap.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/include/lookup_ldap.h
++++ b/include/lookup_ldap.h
+@@ -1,7 +1,9 @@
+ #ifndef LOOKUP_LDAP_H
+ #define LOOKUP_LDAP_H
+
++#ifdef WITH_LDAP
+ #include <ldap.h>
++#endif
+
+ #ifdef WITH_SASL
+ #include <openssl/ssl.h>
+@@ -109,10 +111,12 @@
+
+ #define LDAP_AUTH_USESIMPLE 0x0008
+
++#ifdef WITH_LDAP
+ /* lookup_ldap.c */
+ LDAP *init_ldap_connection(unsigned logopt, const char *uri, struct lookup_context *ctxt);
+ int unbind_ldap_connection(unsigned logopt, LDAP *ldap, struct lookup_context *ctxt);
+ int authtype_requires_creds(const char *authtype);
++#endif
+
+ #ifdef WITH_SASL
+ /* cyrus-sasl.c */
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index bf679b4e65..1afbe812a1 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -3,7 +3,9 @@ SECTION = "base"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-DEPENDS += "openldap libtirpc flex-native bison-native"
+PR = "r1"
+
+DEPENDS += "libtirpc flex-native bison-native"
inherit autotools
@@ -31,6 +33,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
file://libtirpc.patch \
file://libtirpc-name-clash-backout.patch \
file://autofs-5.0.7-do-not-check-for-modprobe.patch \
+ file://fix_disable_ldap.patch \
"
SRC_URI[md5sum] = "bc46838dece83c02d800ff144ed9f431"