aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCatalin Enache <catalin.enache@windriver.com>2016-03-30 12:08:07 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-12 11:07:33 +0200
commitd3e1334ce915cfa8516c26e78c6925c9a5b4f45b (patch)
treea02d5d08e8af561af47bf80d5e29709c23f05bb2
parent83c0fd36761e1224f08d5f6a42c4a0dba33e3bb1 (diff)
downloadmeta-openembedded-contrib-d3e1334ce915cfa8516c26e78c6925c9a5b4f45b.tar.gz
imagemagick: add PACKAGECONFIG for x11
ImageMagick should X11 delegate libraries if they are available Signed-off-by: Catalin Enache <catalin.enache@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb
index 12604c057c..a9f01344a9 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_6.9.2.bb
@@ -20,16 +20,17 @@ inherit autotools pkgconfig update-alternatives
# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
# if someone needs xml support then fix it first
-EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-x --without-perl --disable-openmp --without-xml --disable-opencl"
+EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-perl --disable-openmp --without-xml --disable-opencl"
CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
+PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \