aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-04-26 15:08:42 -0400
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:04 -0700
commitfd1e5eab371d83e24b81f1b2ceeaf0711656a969 (patch)
treebf0ea9d078d437fba6088735b55eec0712136375
parentebb31a9b4ee8827bf6a5ba066fccaf7a35db645b (diff)
downloadmeta-openembedded-contrib-fd1e5eab371d83e24b81f1b2ceeaf0711656a969.tar.gz
mozjs: fix configure host contamination
When building mozjs the following error was observed | Traceback (most recent call last): | File "./config.status", line 9, in <module> | from ConfigStatus import config_status | File "/build/bitbake_build/tmp/work/corei7-64-wrs-linux/mozjs/17.0.0-r0/mozjs17.0.0/js/src/build/ConfigStatus.py", line 11, in <module> | import sys, re, os, posixpath, ntpath | File "/usr/lib/python2.7/ntpath.py", line 15, in <module> | from genericpath import _unicode | ImportError: cannot import name _unicode | WARNING: exit code 1 from a shell command. | ERROR: Function failed: do_configure (log file is located at /build//bitbake_build/tmp/work/corei7-64-wrs-linux/mozjs/17.0.0-r0/temp/do_configure/log.do_configure.1056 Note the host paths found in the error msg. Further this issue can be explored using the host python, which will not error when attempting the above import, and the python in the sysroot, which will fail when we attempt the import. By inheriting pythonnative we ensure the proper paths are set to avoid this host contamination. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index da0578914f..02d56942fa 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -22,7 +22,7 @@ SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c
S = "${WORKDIR}/${BPN}${PV}/js/src"
-inherit autotools pkgconfig perlnative
+inherit autotools pkgconfig perlnative pythonnative
DEPENDS += "nspr zlib"