aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2022-11-12 14:09:51 +0100
committerArmin Kuster <akuster808@gmail.com>2022-11-18 10:11:36 -0500
commitaa811aa7762109661c8978d19ef930059d07d63f (patch)
tree0f316aadcdd9115f4828300d16eb64a2fcc6cb4c
parent16c5d44d421a10510e7d31f9368df5a9560ddd05 (diff)
downloadmeta-openembedded-contrib-aa811aa7762109661c8978d19ef930059d07d63f.tar.gz
chrony: Make it possible to enable editline support again
Support for readline was dropped in Chrony 4.2. However, the --disable-readline option still remains (it is used to completely ignore all forms of command line editing, even though the only remaining variant is editline). So keeping the readline PACKAGECONFIG and making it pass --disable-readline when it is not enabled disabled support for editline, and if it was enabled it instead passed --without-editline, which also disabled support for editline. Thus there was no way to enable editline support. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
-rw-r--r--meta-networking/recipes-support/chrony/chrony_4.3.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta-networking/recipes-support/chrony/chrony_4.3.bb b/meta-networking/recipes-support/chrony/chrony_4.3.bb
index d0e2c4b540..dad09f826c 100644
--- a/meta-networking/recipes-support/chrony/chrony_4.3.bb
+++ b/meta-networking/recipes-support/chrony/chrony_4.3.bb
@@ -53,14 +53,6 @@ USERADD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'privdrop', '${PN}', '
USERADD_PARAM:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'privdrop', '--system -d / -M --shell /bin/nologin chronyd;', '', d)}"
# Configuration options:
-# - For command line editing support in chronyc, you may specify either
-# 'editline' or 'readline' but not both. editline is smaller, but
-# many systems already have readline for other purposes so you might want
-# to choose that instead. However, beware license incompatibility
-# since chrony is GPLv2 and readline versions after 6.0 are GPLv3+.
-# You can of course choose neither, but if you're that tight on space
-# consider dropping chronyc entirely (you can use it remotely with
-# appropriate chrony.conf options).
# - Security-related:
# - 'sechash' is omitted by default because it pulls in nss which is huge.
# - 'privdrop' allows chronyd to run as non-root; would need changes to
@@ -70,7 +62,6 @@ USERADD_PARAM:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'privdrop', '--sys
PACKAGECONFIG ??= "editline \
${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
"
-PACKAGECONFIG[readline] = "--without-editline,--disable-readline,readline"
PACKAGECONFIG[editline] = ",--without-editline,libedit"
PACKAGECONFIG[sechash] = "--without-tomcrypt,--disable-sechash,nss"
PACKAGECONFIG[privdrop] = "--with-libcap,--disable-privdrop --without-libcap,libcap"
@@ -79,6 +70,10 @@ PACKAGECONFIG[ipv6] = ",--disable-ipv6,"
PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
+# This is left for backwards compatibility, to avoid breaking existing
+# configurations.
+PACKAGECONFIG[readline] = ""
+
# --disable-static isn't supported by chrony's configure script.
DISABLE_STATIC = ""