aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Trahm <basti@schleifi.com>2022-10-20 20:03:03 +0200
committerKhem Raj <raj.khem@gmail.com>2022-10-20 15:31:40 -0700
commitbd8defdcd8b6c8e50c7b90587c551d6505f6487c (patch)
tree61b5acb3c1c800cfd3bdf9c1a4952f80b0657cc1
parent30903dd79e0ee659791273b6e75598d9b121fb8c (diff)
downloadmeta-openembedded-contrib-bd8defdcd8b6c8e50c7b90587c551d6505f6487c.tar.gz
Add recipe for python3-pytest-json-report
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-json-report_1.5.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-json-report_1.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-json-report_1.5.0.bb
new file mode 100644
index 0000000000..493c241df2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-json-report_1.5.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "pytest-json-report is a plugin that creates test reports as JSON"
+HOMEPAGE = "https://github.com/numirias/pytest-json-report"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8b4ca2f2ad5aaaebd8eb24f262f8fe60"
+
+SRC_URI[sha256sum] = "2dde3c647851a19b5f3700729e8310a6e66efb2077d674f27ddea3d34dc615de"
+
+PYPI_PACKAGE = "pytest-json-report"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytest-metadata \
+"
+