aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-14 20:58:31 -0700
committerKhem Raj <raj.khem@gmail.com>2023-03-14 21:04:13 -0700
commit093077adc12e8b82eefe8feaae2c07224fd68a34 (patch)
tree54cd102b8030dde96b4685557313fda33840ada9
parent1e774dfc31141a9ed3c31f9f4c1bde45b624dc8e (diff)
downloadmeta-openembedded-contrib-093077adc12e8b82eefe8feaae2c07224fd68a34.tar.gz
nodejs: Depend on file-native
Some older distribution e.g. alma8 has a version of file utility which is version 5.33 but more importantly missing this patch [1] from version 5.40 which causes package failures in wasm files e.g. ERROR: nodejs-18.14.2-r0 do_package: Fatal errors occurred in subprocesses: Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/write_file.wasm']' returned non-zero exit status 1. Subprocess output:ERROR: Bad magic format `version %#x (MVP)' (bad format char: #) Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/symlink_loop.wasm']' returned non-zero exit status 1. Subprocess output:ERROR: Bad magic format `version %#x (MVP)' (bad format char: #) Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/notdir.wasm']' returned non-zero exit status 1. Subprocess output:ERROR: Bad magic format `version %#x (MVP)' (bad format char: #) Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/preopen_populates.wasm']' returned non-zero exit status 1. Subprocess output:ERROR: Bad magic format `version %#x (MVP)' (bad format char: #) Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/clock_getres.wasm']' returned non-zero exit status 1. Subprocess output:ERROR: Bad magic format `version %#x (MVP)' (bad format char: #) Command '['file', '-b', '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/nodejs/18.14.2-r0/package/usr/lib/nodejs/ptest/test/wasi/wasm/main_args.wasm']' returned non-zero exit status 1. [1] https://github.com/file/file/commit/85b7ab83257b3191a1a7ca044589a092bcef2bb3 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_18.14.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.14.2.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.14.2.bb
index c92c373746..7361f4039a 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_18.14.2.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.14.2.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2dff1ccca11e333f1388e34f7e2d1de3"
CVE_PRODUCT = "nodejs node.js"
-DEPENDS = "openssl"
+DEPENDS = "openssl file-replacement-native"
DEPENDS:append:class-target = " qemu-native"
DEPENDS:append:class-native = " c-ares-native"
@@ -88,6 +88,8 @@ EXTRA_OEMAKE = "\
builddir_name=./ \
"
+EXTRANATIVEPATH += "file-native"
+
python prune_sources() {
import shutil