aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Horgan <ben.horgan@arm.com>2021-07-16 13:38:07 +0100
committerKhem Raj <raj.khem@gmail.com>2021-07-16 09:23:04 -0700
commit87a7098e0d3d934cfb8cf9c00e0631561c662125 (patch)
treee3e3613cc0e65073277c63bba501581683ea2d6d
parentffceca1f1730db9d85e05825f34a8530d80fe431 (diff)
downloadmeta-openembedded-contrib-87a7098e0d3d934cfb8cf9c00e0631561c662125.tar.gz
cpputest: Add initial recipe. Version 4.0.
Signed-off-by: Ben Horgan <ben.horgan@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/cpputest/cpputest_4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/cpputest/cpputest_4.0.bb b/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
new file mode 100644
index 0000000000..a17c0658c3
--- /dev/null
+++ b/meta-oe/recipes-test/cpputest/cpputest_4.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "CppUTest unit testing and mocking framework for C/C++"
+HOMEPAGE = "http://cpputest.github.io/"
+SECTION = "devel"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ce5d5f1fe02bcd1343ced64a06fd4177"
+
+SRC_URI = "git://github.com/cpputest/cpputest.git;protocol=https"
+SRCREV = "67d2dfd41e13f09ff218aa08e2d35f1c32f032a1"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DLONGLONG=ON \
+ -DC++11=ON \
+ -DTESTS=OFF \
+ -DEXTENSIONS=OFF \
+ "
+
+FILES_${PN}-dev += "${libdir}/CppUTest/cmake/*"