aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet <ruben.de.smet@rubdos.be>2016-09-29 15:30:54 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 15:22:58 +0200
commit1e5818580a5151935102656cb441cd92775cb3c9 (patch)
treeb33f6ff84f66889f2698a3ba8b8137b73d1c44aa
parent8ff6996f693d1d717a6f8e2c876bb9e1819b0849 (diff)
downloadmeta-openembedded-contrib-1e5818580a5151935102656cb441cd92775cb3c9.tar.gz
python-scales: add recipe for version 1.0.9
A python module for tracking server state and statisticst Signed-off-by: Ruben De Smet <ruben.de.smet@rubdos.be> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-scales.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-scales_1.0.9.bb11
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-scales.inc b/meta-python/recipes-devtools/python/python-scales.inc
new file mode 100644
index 0000000000..5a46e2bbdc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-scales.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Metrics for Python"
+DESCRIPTION = "Tracks server state and statistics, allowing you to see what \
+your server is doing. It can also send metrics to Graphite for graphing or to \
+a file for crash forensics."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+# LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+SRCNAME = "scales"
+
+SRC_URI[md5sum] = "c61167f2b5f506f0a34a7b8a295a9567"
+SRC_URI[sha256sum] = "8b6930f7d4bf115192290b44c757af5e254e3fcfcb75ff9a51f5c96a404e2753"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-scales_1.0.9.bb b/meta-python/recipes-devtools/python/python3-scales_1.0.9.bb
new file mode 100644
index 0000000000..ecf6c672a3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scales_1.0.9.bb
@@ -0,0 +1,11 @@
+inherit setuptools3
+require python-scales.inc
+
+RDEPENDS_${PN} += "\
+ python3-six \
+"
+
+DEPENDS_${PN} += "\
+ python3-setuptools \
+"
+