aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-28 13:58:14 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-04 09:18:33 +0200
commit474eb0daa573e4d26e24e51011fb145da249c6d0 (patch)
tree834ad5df6b502890c09ba21d6690bb0da5044944
parent6ad29368c00bdc61613465cca007d77bdd687de0 (diff)
downloadmeta-openembedded-contrib-474eb0daa573e4d26e24e51011fb145da249c6d0.tar.gz
python-pygobject: remove the empty pkgconfig directory
The empty pkgconfif directory causes error when run relocatable_native_pcfiles: | sed: can't read /path/to/recipe-sysroot-native/usr/lib/pkgconfig/*.pc: No such file or directory So remove the directory instead of removing the pc file but left an empty pkgconfig diretory. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
index 952145f1ef..acc2f5b7a6 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.22.0.bb
@@ -30,5 +30,5 @@ RDEPENDS_${PN}_class-native = ""
do_install_append() {
# Remove files that clash with python3-pygobject; their content is same
- rm ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig/pygobject-3.0.pc
+ rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig
}