aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit532b1c0566997ee1e29c0697f700e7aa11070882 (patch)
tree336e781a59d4c20d5d6544e7189dab9637ac9af1
parent2be0c8b29b3f02cdb6d6b52e5b349a9a45e9b8c8 (diff)
downloadmeta-openembedded-contrib-532b1c0566997ee1e29c0697f700e7aa11070882.tar.gz
open-vm-tools: support FUSE
The vmhgfs driver is now gone, but they use FUSE instead. Add FUSE support so we don't lose the functionality vmhgfs use to provide. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index c3cb9d5677..7d024f2602 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -47,6 +47,9 @@ NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
+# fuse gets implicitly detected; there is no --without-fuse option.
+PACKAGECONFIG[fuse] = ",,fuse"
+
CFLAGS += '-Wno-error=deprecated-declarations'
FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \