aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-02-22 19:16:43 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-23 23:22:31 +0100
commit594e949b8d61a70555fa4a902c57713b42134459 (patch)
treef5ef0407eab35d4e7638b943658f922de7a2880a
parent5fd25205ac2546cb3fdc6fb21def108c2f86c0c1 (diff)
downloadmeta-openembedded-contrib-594e949b8d61a70555fa4a902c57713b42134459.tar.gz
python-tornado: update to version 4.4.2
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-tornado.inc6
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.4.2.bb (renamed from meta-python/recipes-devtools/python/python-tornado_4.3.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_4.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_4.4.2.bb7
4 files changed, 10 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado.inc b/meta-python/recipes-devtools/python/python-tornado.inc
index 7e3ac8c810..9b1cf41288 100644
--- a/meta-python/recipes-devtools/python/python-tornado.inc
+++ b/meta-python/recipes-devtools/python/python-tornado.inc
@@ -6,11 +6,11 @@ HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://setup.py;startline=2;endline=15;md5=5ab7571a79ad62d0ca7aea308bac7560"
-SRC_URI[md5sum] = "d13a99dc0b60ba69f5f8ec1235e5b232"
-SRC_URI[sha256sum] = "c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf"
+SRC_URI[md5sum] = "b4816ea209118667ffc52ce9ff06ac85"
+SRC_URI[sha256sum] = "2898f992f898cd41eeb8d53b6df75495f2f423b6672890aadaf196ea1448edcc"
RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email ${PYTHON_PN}-subprocess \
- ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi"
+ ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading"
RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.4.2.bb
index 5d11475567..5d11475567 100644
--- a/meta-python/recipes-devtools/python/python-tornado_4.3.bb
+++ b/meta-python/recipes-devtools/python/python-tornado_4.4.2.bb
diff --git a/meta-python/recipes-devtools/python/python3-tornado_4.3.bb b/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
deleted file mode 100644
index eecc1f0fb4..0000000000
--- a/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-tornado.inc
diff --git a/meta-python/recipes-devtools/python/python3-tornado_4.4.2.bb b/meta-python/recipes-devtools/python/python3-tornado_4.4.2.bb
new file mode 100644
index 0000000000..77c9fb516f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tornado_4.4.2.bb
@@ -0,0 +1,7 @@
+inherit pypi setuptools3
+require python-tornado.inc
+
+# Requires _compression which is currently located in misc
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-misc \
+ "