aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-10 09:14:28 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:36 +0200
commitd27ad560bed58caf6c460c159315b9424f63710f (patch)
treeea2af4ec8c43db05d4d7bb2924919e510b59be2d
parent63ebe282aa03ac8e5d39d1017e743695d0795c41 (diff)
downloadmeta-openembedded-contrib-d27ad560bed58caf6c460c159315b9424f63710f.tar.gz
python-ujson: correct RDEPENDS to pull in needed python packages
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-ujson_1.35.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-ujson_1.35.bb b/meta-python/recipes-devtools/python/python-ujson_1.35.bb
index 29207f3c53..4ef3d1822c 100644
--- a/meta-python/recipes-devtools/python/python-ujson_1.35.bb
+++ b/meta-python/recipes-devtools/python/python-ujson_1.35.bb
@@ -10,4 +10,7 @@ SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a22
PYPI_PACKAGE = "ujson"
inherit pypi setuptools
-RDEPENDS_${PN} += "python-numbers"
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+ "