aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-08-27 12:28:03 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commite975dd7786bdb55c6db34fcaf685df49fc4ba080 (patch)
tree0f6ec29143277811aac920bca2742b6777394ffd
parent059b3b24747e96c2220e13f3078b3fd93e96e468 (diff)
downloadmeta-openembedded-contrib-e975dd7786bdb55c6db34fcaf685df49fc4ba080.tar.gz
python-subprocess32: add recipe for v3.2.7
A backport of the subprocess module from Python 3.2 for use on 2.x Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-subprocess32_3.2.7.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-subprocess32_3.2.7.bb b/meta-python/recipes-devtools/python/python-subprocess32_3.2.7.bb
new file mode 100644
index 0000000000..f43706923a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-subprocess32_3.2.7.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A backport of the subprocess module from Python 3.2 for use on 2.x"
+DESCRIPTION = "This is a backport of the subprocess standard library module \
+from Python 3.2 - 3.5 for use on Python 2. It includes bugfixes and some new \
+features. On POSIX systems it is guaranteed to be reliable when used in \
+threaded applications. It includes timeout support from Python 3.3 and the \
+run() API from 3.5 but otherwise matches 3.2's API."
+LICENSE = "Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d3e62baa8fb96b11a59d3f2cd335d5c0"
+
+SRC_URI[md5sum] = "824c801e479d3e916879aae3e9c15e16"
+SRC_URI[sha256sum] = "1e450a4a4c53bf197ad6402c564b9f7a53539385918ef8f12bdf430a61036590"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native nativesdk"