aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-03-13 16:48:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-16 23:34:32 +0100
commitebd31fd8d519d3e2d26dd14e72d36300f433cfa0 (patch)
treeba98498c66b8cb45251cf631ba9e7b9aaa3dbfb5
parent4b4a62ec0760873b96b738751bf9492aa2efb922 (diff)
downloadmeta-openembedded-contrib-ebd31fd8d519d3e2d26dd14e72d36300f433cfa0.tar.gz
meta: do not prepend/append to BBCLASSEXTEND
Replace some "+=/=+" with "=" when setting BBCLASSEXTEND, they are redundant and inconsistent with the same setting in other recipes. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb2
-rw-r--r--meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb2
-rw-r--r--meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb2
-rw-r--r--meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb2
-rw-r--r--meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb2
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb2
-rw-r--r--meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb2
-rw-r--r--meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb2
-rw-r--r--meta-oe/recipes-support/lzip/lzip_1.16.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb2
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb2
11 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb b/meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb
index 8fe6a6f9c8..288c586a5d 100644
--- a/meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb
+++ b/meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb
@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "fdee1e69903cf409bdc6f32403a566cbc6006aa9e2a4d6f8f12b90dfd5
inherit autotools pkgconfig
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
index f39a82ccc6..34fddcbda7 100644
--- a/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
+++ b/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb
@@ -165,4 +165,4 @@ FILES_${PN}-fstools = "\
${bindir}/mkuserimg \
"
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb b/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
index dff6cc1614..53bbf7eee4 100644
--- a/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
+++ b/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
@@ -21,4 +21,4 @@ inherit cmake
FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake"
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
index 3105f65c37..b8d15835b3 100644
--- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
+++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb
@@ -45,4 +45,4 @@ PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'demos', '${PN}-demos', '', d
FILES_${PN}-demos = "${bindir}/*"
FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibRcf.cmake"
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb b/meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb
index c2f5ec0dcb..31ab9a69c9 100644
--- a/meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb
+++ b/meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb
@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "ad5ec3b62f2f0bdc7f06fa398bde61091fd2493e91059e17315b519742
inherit autotools pkgconfig
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
index fdd51db218..67ffbc67ce 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -36,4 +36,4 @@ EOF
chmod 0755 ${D}${bindir}/7z
}
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb b/meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb
index 155d3d484d..c62dab1336 100644
--- a/meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb
+++ b/meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb
@@ -23,4 +23,4 @@ PACKAGECONFIG ??= "openssl"
PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
index 4460be2073..138df9f300 100644
--- a/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
+++ b/meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb
@@ -42,4 +42,4 @@ do_install() {
install -m 0644 ${S}/tinyxml.h ${D}${includedir}
}
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"
diff --git a/meta-oe/recipes-support/lzip/lzip_1.16.bb b/meta-oe/recipes-support/lzip/lzip_1.16.bb
index af0b6ae8e6..a5d99625a7 100644
--- a/meta-oe/recipes-support/lzip/lzip_1.16.bb
+++ b/meta-oe/recipes-support/lzip/lzip_1.16.bb
@@ -38,4 +38,4 @@ do_install () {
fi
}
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
index afbc83ea99..08008cec06 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
@@ -10,6 +10,6 @@ PYPI_PACKAGE = "setuptools_scm"
RDEPENDS_${PN}_class-target = "python-py python-setuptools python-argparse python-debugger python-json"
RDEPENDS_${PN}_class-native = "python-setuptools-native"
-BBCLASSEXTEND =+ "native"
+BBCLASSEXTEND = "native"
inherit pypi setuptools
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
index 712c4b97ab..8335d08c32 100644
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
@@ -24,4 +24,4 @@ inherit distutils
RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
RDEPENDS_${PN}_class-native = ""
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"