aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-04-24 11:13:20 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2020-06-29 19:33:55 +0200
commit5a95ef54bc3f4a1d3f242aef0b83318450576b90 (patch)
tree5780ce9b7efae2dd323b0d1660f8ca851d1226e1
parent5ab1e24fb08515ecc9470d70612993447aa689d7 (diff)
downloadmeta-openembedded-contrib-5a95ef54bc3f4a1d3f242aef0b83318450576b90.tar.gz
daemontools: use u-a for /usr/bin/svc and /usr/bin/svok
* busybox provides the same, causing busybox postinst to fail when both packages are installed in the same image: update-alternatives: Error: not linking rootfs/usr/bin/svc to /usr/bin/busybox.nosuid since rootfs/usr/bin/svc exists and is not a link update-alternatives: Error: not linking rootfs/usr/bin/svok to /usr/bin/busybox.nosuid since rootfs/usr/bin/svok exists and is not a link Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/daemontools/daemontools_0.76.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/daemontools/daemontools_0.76.bb b/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
index b99116da70..f0c5f7d7de 100644
--- a/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
+++ b/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
@@ -38,3 +38,7 @@ do_install() {
do_install_append_class-target() {
install -m755 ${S}/command/* ${D}/${bindir}
}
+
+inherit update-alternatives
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "svc svok"