aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-18 15:52:07 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-25 10:40:50 -0700
commit69fe208d2e6ede3d2791d2728a42cf235006ad90 (patch)
tree2b556a483ef6c55e31d7fae2146de40d80c26f64
parent13a33fda76d1333100bdde6625b21c5bf760f199 (diff)
downloadmeta-openembedded-contrib-69fe208d2e6ede3d2791d2728a42cf235006ad90.tar.gz
lvgl: Lint recipe
Forwarded: https://github.com/openembedded/meta-openembedded/pull/461 Relate-to: https://github.com/lvgl/lvgl/issues/2534 Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb23
1 files changed, 8 insertions, 15 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
index 5f37efda79..2ca7f60e85 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_8.0.3.bb
@@ -1,19 +1,16 @@
-# -*- mode: bitbake; c-basic-offset: 4; indent-tabs-mode: nil -*-
-
# SPDX-FileCopyrightText: Huawei Inc.
+#
# SPDX-License-Identifier: MIT
-# TODO: Pin upstream release (current is v8.0.3-dev-239-g7b7bed37d)
-src_org = "lvgl"
-SRC_URI = "gitsm://github.com/${src_org}/lvgl;destsuffix=${S};protocol=https;nobranch=1"
-SRCREV = "7b7bed37d3e937c59ec99fccba58774fbf9f1930"
-
+HOMEPAGE = "https://lvgl.io/"
+DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI"
+SUMMARY = "Light and Versatile Graphics Library"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
-HOMEPAGE = "https://lvgl.io/"
-SUMMARY = "Light and Versatile Graphics Library"
-DESCRIPTION = "LVGL is an open-source graphics library providing everything you need to create embedded GUI with easy-to-use graphical elements, beautiful visual effects and low memory footprint."
+# TODO: Pin upstream release (current is v8.0.3-dev-239-g7b7bed37d)
+SRC_URI = "gitsm://github.com/lvgl/lvgl;destsuffix=${S};protocol=https;nobranch=1"
+SRCREV = "7b7bed37d3e937c59ec99fccba58774fbf9f1930"
REQUIRED_DISTRO_FEATURES = "wayland"
@@ -24,17 +21,13 @@ S = "${WORKDIR}/${PN}-${PV}"
EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
-
do_configure:prepend() {
[ -r "${S}/lv_conf.h" ] \
|| sed -e "s|#if 0 /*Set it to \"1\" to enable the content*/|#if 1 // Enabled by ${PN}|g" \
< "${S}/lv_conf_template.h" > "${S}/lv_conf.h"
}
-
-FILES:${PN}-dev = "\
+FILES:${PN}-dev += "\
${includedir}/${PN}/ \
${includedir}/${PN}/lvgl/ \
"
-
-FILES:${PN}-staticdev = "${libdir}/"