aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-20 21:11:01 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-25 10:40:50 -0700
commita3ef694b82a768ef9cf21d23c0f3f050f76479da (patch)
tree43f2d373cba9f8df77a8bf62d87f14c54fccb811
parent087faa12088cc7c7d9e9addcaf36f1b361e3462e (diff)
downloadmeta-openembedded-contrib-a3ef694b82a768ef9cf21d23c0f3f050f76479da.tar.gz
gjs: Upgrade to 1.70.0 + mozjs-91 branchkraj/gjs
This is an attempt to fix the build, its needs some more work though Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch33
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch77
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch48
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb42
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb34
5 files changed, 82 insertions, 152 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch
deleted file mode 100644
index 0953214fbf..0000000000
--- a/meta-gnome/recipes-gnome/gjs/gjs/0001-Disable-tests-on-host.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 95379de2132786f855e8caec1fd5869225774d02 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
-Date: Sat, 18 May 2019 01:14:07 +0200
-Subject: [PATCH] Disable tests on host
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Inappropriate [OE-specific]
-
-Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
----
- configure.ac | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index fa4e136..056e96e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -335,9 +335,7 @@ AS_IF([test "x$with_dbus_tests" != "xno"], [
- ])
- AM_CONDITIONAL([DBUS_TESTS], [test "x$with_dbus_tests" != "xno"])
-
--AC_MSG_CHECKING([for a suitable UTF-8 locale to run the tests in])
--TESTS_LOCALE=$($srcdir/build/choose-tests-locale.sh)
--AC_MSG_RESULT([$TESTS_LOCALE])
-+TESTS_LOCALE=C
- AC_SUBST([TESTS_LOCALE])
-
- AC_SUBST([gjsjsdir], [\${datadir}/gjs-1.0])
---
-2.20.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch
deleted file mode 100644
index 6343a24a2d..0000000000
--- a/meta-gnome/recipes-gnome/gjs/gjs/0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From dae0055be61937fe70252f3f4ee09b355aba2b8f Mon Sep 17 00:00:00 2001
-From: Philip Chimento <philip.chimento@gmail.com>
-Date: Sun, 14 Feb 2021 12:20:09 -0800
-Subject: [PATCH] maint: Avoid g_once_init_enter error in GCC 11
-
-On platforms where g_once_init_enter() is defined to use C11 atomic
-builtins, passing a pointer to a volatile value is an error in GCC 11 and
-later, in C++.
-
-More info about the GCC change:
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95378
-https://gcc.gnu.org/pipermail/gcc-patches/2020-June/548283.html
-
-However, it's my understanding that in modern C++ there is no longer a
-need to guard the initialization of these variables. Since C++11, static
-local variables in a function are guaranteed to be initialized only once,
-the first time control passes through that function. So we can just remove
-the g_once_init_enter guard.
-
-More info:
-https://en.cppreference.com/w/cpp/language/storage_duration#Static_local_variables
-
-Stack Overflow answers with quotations from the C++ standard:
-https://stackoverflow.com/a/58804/172999
-https://stackoverflow.com/a/8102145/172999
-
-Closes: #376
----
- gjs/error-types.cpp | 32 +++++++++++++-------------------
- 1 file changed, 13 insertions(+), 19 deletions(-)
-
-Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gjs/-/commit/f02eaf3a9d3465915eb849428c2d9615e2184a4c]
-diff --git a/gjs/error-types.cpp b/gjs/error-types.cpp
-index 86cb878..5eba61b 100644
---- a/gjs/error-types.cpp
-+++ b/gjs/error-types.cpp
-@@ -31,24 +31,18 @@ G_DEFINE_QUARK(gjs-js-error-quark, gjs_js_error)
- // clang-format on
-
- GType gjs_js_error_get_type(void) {
-- static volatile GType g_type_id;
--
-- if (g_once_init_enter(&g_type_id)) {
-- static GEnumValue errors[] = {
-- { GJS_JS_ERROR_ERROR, "Error", "error" },
-- { GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error" },
-- { GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error" },
-- { GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error" },
-- { GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error" },
-- { GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration" },
-- { GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error" },
-- { GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error" },
-- { GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error" },
-- { 0, nullptr, nullptr }
-- };
--
-- g_type_id = g_enum_register_static("GjsJSError", errors);
-- }
--
-+ static const GEnumValue errors[] = {
-+ {GJS_JS_ERROR_ERROR, "Error", "error"},
-+ {GJS_JS_ERROR_EVAL_ERROR, "EvalError", "eval-error"},
-+ {GJS_JS_ERROR_INTERNAL_ERROR, "InternalError", "internal-error"},
-+ {GJS_JS_ERROR_RANGE_ERROR, "RangeError", "range-error"},
-+ {GJS_JS_ERROR_REFERENCE_ERROR, "ReferenceError", "reference-error"},
-+ {GJS_JS_ERROR_STOP_ITERATION, "StopIteration", "stop-iteration"},
-+ {GJS_JS_ERROR_SYNTAX_ERROR, "SyntaxError", "syntax-error"},
-+ {GJS_JS_ERROR_TYPE_ERROR, "TypeError", "type-error"},
-+ {GJS_JS_ERROR_URI_ERROR, "URIError", "uri-error"},
-+ {0, nullptr, nullptr}};
-+ // Initialization of static local variable guaranteed only once in C++11
-+ static GType g_type_id = g_enum_register_static("GjsJSError", errors);
- return g_type_id;
- }
---
-2.31.1
-
diff --git a/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch b/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch
new file mode 100644
index 0000000000..da5a990326
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs/0001-meson-Disable-runtime-checks.patch
@@ -0,0 +1,48 @@
+From 399ad6ab6d5234199e17df2a16509549943646ce Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 20 Oct 2021 20:31:55 -0700
+Subject: [PATCH] meson: Disable runtime checks
+
+Wont work in cross compile case
+
+Upstream-Status: Inappropriate [Cross-compile specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ meson.build | 21 ---------------------
+ 1 file changed, 21 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index b8112c16..37c6fdd4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -252,27 +252,6 @@ release builds of SpiderMonkey. Try configuring SpiderMonkey with
+ --disable-debug.''')
+ endif
+
+-# Check if a minimal SpiderMonkey program compiles, links, and runs. If not,
+-# it's most likely the case that SpiderMonkey was configured incorrectly, for
+-# example by building mozglue as a shared library.
+-minimal_program = cxx.run('''
+-#include <js/Initialization.h>
+-int main(void) {
+- if (!JS_Init()) return 1;
+- JS_ShutDown();
+- return 0;
+-}
+-''',
+- args: debug_arg, dependencies: spidermonkey,
+- name: 'SpiderMonkey sanity check')
+-
+-if not minimal_program.compiled() or minimal_program.returncode() != 0
+- error('''A minimal SpiderMonkey program
+-could not be compiled, linked, or run. Most likely you should build it with a
+-different configuration. Check the recommended configuration:
+-https://github.com/spidermonkey-embedders/spidermonkey-embedding-examples/blob/esr91/docs/Building%20SpiderMonkey.md''')
+-endif
+-
+ have_printf_alternative_int = cc.compiles('''
+ #include <stdio.h>
+ int main(void) {
+--
+2.33.1
+
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
deleted file mode 100644
index 096e277bb4..0000000000
--- a/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-SUMMARY = "Javascript bindings for GNOME"
-LICENSE = "MIT & LGPLv2+"
-LIC_FILES_CHKSUM = " \
- file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
- file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
-"
-
-GNOMEBASEBUILDCLASS = "autotools"
-
-DEPENDS = "mozjs gtk+3"
-
-inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even pkgconfig
-
-SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381"
-SRC_URI += "file://0001-Disable-tests-on-host.patch \
- file://0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch \
-"
-
-# gobject-introspection is mandatory and cannot be configured
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST:append = " --enable-introspection --disable-introspection"
-
-EXTRA_OECONF = " \
- --without-dbus-tests \
- --disable-installed-tests \
-"
-
-do_configure:prepend() {
- # make configure find gobject-introspection test code. Although we set
- # --disable-installed-tests gjs builds them
- sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
-}
-
-FILES:${PN} += "${datadir}/gjs-1.0/lsan"
-
-PACKAGES =+ "${PN}-valgrind"
-FILES:${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
-RDEPENDS:${PN}-valgrind += "valgrind"
-
-# Valgrind not yet available on rv32/rv64
-RDEPENDS:${PN}-valgrind:remove:riscv32 = "valgrind"
-RDEPENDS:${PN}-valgrind:remove:riscv64 = "valgrind"
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
new file mode 100644
index 0000000000..d5f10ff3f5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Javascript bindings for GNOME"
+LICENSE = "MIT & LGPLv2+"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=8dcea832f6acf45d856abfeb2d51ec48 \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+DEPENDS = "mozjs gtk+3 dbus gobject-introspection libffi cairo"
+
+inherit gnomebase gsettings gobject-introspection gobject-introspection-data vala gettext features_check upstream-version-is-even pkgconfig
+
+PV .= "+git${SRCPV}"
+SRCREV = "e41f247f8c170d125ce968ed236ae7249e966178"
+SRC_URI = "git://gitlab.gnome.org/GNOME/gjs;protocol=https;branch=mozjs91 \
+ file://0001-meson-Disable-runtime-checks.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMESON += "-Dinstalled_tests=false -Dskip_dbus_tests=true -Dskip_gtk_tests=true -Dprofiler=disabled"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+
+FILES:${PN} += "${datadir}/gjs-1.0/lsan"
+
+PACKAGES =+ "${PN}-valgrind"
+FILES:${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
+RDEPENDS:${PN}-valgrind += "valgrind"
+
+# Valgrind not yet available on rv32/rv64
+RDEPENDS:${PN}-valgrind:remove:riscv32 = "valgrind"
+RDEPENDS:${PN}-valgrind:remove:riscv64 = "valgrind"