aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 16:35:08 -0500
committerMark Hatle <mark.hatle@windriver.com>2017-09-06 15:06:41 -0500
commit3fe2e67bba940ae2c61754028593ede2d5f5f1a0 (patch)
tree6668c43c15d4389ea4882e884c10dcf86c9116c4
parent3dd66393f484cdcaa298923d3d012ba8759ee274 (diff)
downloadmeta-openembedded-contrib-3fe2e67bba940ae2c61754028593ede2d5f5f1a0.tar.gz
open-vm-tools: only build if meta-networking and meta-filesystems is available
libdnet - meta-networking fuse - meta-filesystems Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index dc8faa4ead..81e8e96249 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -94,3 +94,10 @@ do_configure_prepend() {
export CUSTOM_DNET_NAME=dnet
export CUSTOM_DNET_LIBS=-L${STAGING_LIBDIR}/libdnet.so
}
+
+python() {
+ if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split() or \
+ 'filesystems-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-networking and meta-filesystems to be present.')
+}
+