aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-02 15:05:58 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-05 14:34:50 +0200
commitede7768d36ef70f1fbc5eb185618b87d9e38f1d0 (patch)
treed827eb8178b93c83540f402ba2b79efab2a738c1
parent7b92849e1a18245986e8cf4909bd65d6b396dbb4 (diff)
downloadmeta-openembedded-contrib-ede7768d36ef70f1fbc5eb185618b87d9e38f1d0.tar.gz
open-vm-tools: Add -Wno-address-of-packed-member for with clang
This option ignores a warning as following error: taking address of packed member 'actualSize' of class or structure 'HgfsReplyReadV3' may result in an unaligned pointer value Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index f7746c8e35..dc8faa4ead 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -66,6 +66,7 @@ PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
# fuse gets implicitly detected; there is no --without-fuse option.
PACKAGECONFIG[fuse] = ",,fuse"
+CFLAGS_append_toolchain-clang = " -Wno-address-of-packed-member"
FILES_${PN} += "\
${libdir}/open-vm-tools/plugins/vmsvc/lib*.so \
${libdir}/open-vm-tools/plugins/common/lib*.so \