aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2014-01-22 15:57:01 +0800
committerAndreas Oberritter <obi@opendreambox.org>2015-04-22 10:07:57 +0200
commit021f93f8e152b58b3a05c622e939260b9d5dee23 (patch)
treee1034c86fbcc5eb3f365532964c0a566c0eb5fc0
parent0e036a92b8ddde8e156f1d12154ea3477fb253ed (diff)
downloadmeta-openembedded-contrib-021f93f8e152b58b3a05c622e939260b9d5dee23.tar.gz
samba: add PACKAGECONFIG for libunwind
Also add --enable-libunwind option for samba source3, otherwise, it will be auto-detected from sysroot, which will lead implicit results. Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 79a0ab967000360889381d5d5e2c32d7073e2741) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-oe/recipes-connectivity/samba/samba-3.6.8/configure-libunwind.patch82
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_3.6.8.bb4
2 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba-3.6.8/configure-libunwind.patch b/meta-oe/recipes-connectivity/samba/samba-3.6.8/configure-libunwind.patch
new file mode 100644
index 0000000000..9a2cb00eba
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba-3.6.8/configure-libunwind.patch
@@ -0,0 +1,82 @@
+samba: add --enable-libunwind option
+
+Upstream-Status: Pending
+
+This let the end user explicitly enable/disable libunwind support.
+---
+ configure | 28 ++++++++++++++++++++++++++--
+ 1 file changed, 26 insertions(+), 2 deletions(-)
+
+diff -urpN a/source3/configure b/source3/configure
+--- a/source3/configure
++++ b/source3/configure
+@@ -1007,6 +1007,7 @@ with_included_iniparser
+ with_static_modules
+ with_shared_modules
+ enable_dmalloc
++enable_libunwind
+ '
+ ac_precious_vars='build_alias
+ host_alias
+@@ -1670,6 +1671,7 @@ Optional Features:
+ --enable-avahi Enable Avahi support (default=auto)
+ --enable-pthreadpool Enable pthreads pool helper support (default=no)
+ --enable-dmalloc Enable heap debugging [default=no]
++ --enable-libunwind Enable libunwind support if available (default=no)
+
+ Optional Packages:
+ --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
+@@ -16458,7 +16460,7 @@ done
+
+
+ # Find a method of generating a stack trace
+-for ac_header in execinfo.h libexc.h libunwind.h
++for ac_header in execinfo.h libexc.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
+@@ -16684,6 +16686,13 @@ fi
+
+ LIBS="$save_LIBS"
+
++# Check whether --enable-libunwind was given.
++if test "${enable_libunwind+set}" = set; then :
++ enableval=$enable_libunwind;
++fi
++
++if test "x$enable_libunwind" != xno
++then
+ # Note that all the libunwind symbols in the API are defined to internal
+ # platform-specific version, so we must include libunwind.h before checking
+ # any of them.
+@@ -16691,6 +16700,21 @@ LIBS="$save_LIBS"
+ $as_echo_n "checking for libunwind... " >&6; }
+ save_LIBS=$LIBS
+
++# Check for libunwind.h present
++for ac_header in libunwind.h
++do :
++ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
++ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
++eval as_val=\$$as_ac_Header
++ if test "x$as_val" = x""yes; then :
++ cat >>confdefs.h <<_ACEOF
++#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
++_ACEOF
++
++fi
++
++done
++
+ UNWIND_ARCH="unknown"
+ if test x"$UNAME_I" != x"unknown"; then
+ UNWIND_ARCH="$UNAME_I"
+@@ -16877,7 +16901,7 @@ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ fi
+-
++fi
+
+
+ for ac_func in _dup _dup2 _opendir _readdir _seekdir _telldir _closedir
diff --git a/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb b/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
index 255c0b4868..20b609de5f 100644
--- a/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
+++ b/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
@@ -29,12 +29,16 @@ SRC_URI += "\
file://only_export_public_symbols.patch;patchdir=.. \
file://configure-disable-getaddrinfo-cross.patch;patchdir=.. \
file://configure-disable-core_pattern-cross-check.patch;patchdir=.. \
+ file://configure-libunwind.patch;patchdir=.. \
"
SRC_URI[md5sum] = "fbb245863eeef2fffe172df779a217be"
SRC_URI[sha256sum] = "4f5a171a8d902c6b4f822ed875c51eb8339196d9ccf0ecd7f6521c966b3514de"
S = "${WORKDIR}/samba-${PV}/source3"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
+
EXTRA_OECONF += "\
ac_cv_path_PYTHON=/not/exist \
ac_cv_path_PYTHON_CONFIG=/not/exist \