aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-05-05 17:09:11 +0300
committerAndreas Oberritter <obi@opendreambox.org>2020-02-03 23:20:16 +0100
commite53936c61456d13387fa61de5128fd11250058e5 (patch)
tree99ab40079765ef4dbac602ae732d70c534d71834
parentde8c0b175b72b717cf690c76b967a3bca98f3e21 (diff)
downloadmeta-openembedded-contrib-e53936c61456d13387fa61de5128fd11250058e5.tar.gz
python-six: re-add the recipe for Python 2.x
python-six was removed from oe-core, so we should provide it in meta-oe. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 04d5ee72720135e5f859b0a6a376408b3ac00dae) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta-python/recipes-devtools/python/python-six.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-six_1.10.0.bb2
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-six.inc b/meta-python/recipes-devtools/python/python-six.inc
new file mode 100644
index 0000000000..e33c01ded3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-six.inc
@@ -0,0 +1,18 @@
+SUMMARY = "Python 2 and 3 compatibility library"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6f00d4a50713fa859858dd9abaa35b21"
+
+SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55"
+SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a"
+
+do_compile_append() {
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+do_install_append() {
+ install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}
+
+RDEPENDS_${PN} += "${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/meta-python/recipes-devtools/python/python-six_1.10.0.bb b/meta-python/recipes-devtools/python/python-six_1.10.0.bb
new file mode 100644
index 0000000000..9075745d74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-six_1.10.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-six.inc