aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2015-01-19 13:06:59 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 09:51:42 +0100
commit66a1ccc69dff76bc1cc0be983160eea38137a0de (patch)
tree5741045e8520847e0083595b3af75cdf304f28d9
parent8912083e23e0fde68a2619f3df6b48e2e6f28197 (diff)
downloadmeta-openembedded-contrib-66a1ccc69dff76bc1cc0be983160eea38137a0de.tar.gz
python-ldap: move to version 2.4.10
Retain 2.3.9 in case configuration differences matter to some people. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-ldap_2.4.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-ldap_2.4.10.bb b/meta-python/recipes-devtools/python/python-ldap_2.4.10.bb
new file mode 100644
index 0000000000..78a878a15b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ldap_2.4.10.bb
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2012 Wind River Systems, Inc.
+#
+SUMMARY = "Provides a wrapper in Python to LDAP"
+DESCRIPTION = "This module provides access to the LDAP \
+(Lightweight Directory Access Protocol) through Python operations \
+instead of C API. The module mainly acts as a wrapper for the \
+OpenLDAP 2.x libraries. Errors will appear as exceptions."
+
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+HOMEPAGE = "http://www.python-ldap.org/"
+DEPENDS = "python openldap cyrus-sasl"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/${PN}/${BPN}-${PV}.tar.gz"
+
+inherit setuptools
+
+LIC_FILES_CHKSUM = "file://LICENCE;md5=a41c82edffa04912007cae1d20cac555"
+SRC_URI[md5sum] = "a15827ca13c90e9101e5e9405c1d83be"
+SRC_URI[sha256sum] = "67cc7801bf24c29386ab99966ceb68d6a60fa9e0566cc95a4fbb2c4695a8ce54"
+
+do_configure_prepend() {
+ sed -i -e 's:^library_dirs =.*::' setup.cfg
+ sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
+}