aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-09-26 15:48:22 -0300
committerJoe MacDonald <joe_macdonald@mentor.com>2017-10-11 16:22:49 -0400
commit68443bd22e48782a94db7ce6c3d6cd40f42c9c5a (patch)
tree4156cbdb25927fbbd7333f505296a56a9b89abc7
parent960d570d983865bb8e7d48a98776a1707ecf8fa8 (diff)
downloadmeta-openembedded-contrib-68443bd22e48782a94db7ce6c3d6cd40f42c9c5a.tar.gz
lldpd: Update to version 0.9.8
- Remove json packageconfig. See commit: https://github.com/vincentbernat/lldpd/commit/06987a24ce053cbb57f8853bbf544bc7c067c8aa - Add patch to use mkdir from /bin/mkdir in systemd service. - Update from lldpd (0.9.8) * Changes: + "Station" capability is only set if no other bit is set. + Use ethtool to get permanent address for bonds and teams. This might provide different results than the previous method. Some devices may still use the previous method. + Don't run ethtool as root. Kernels older than 2.6.19 won't get link information anymore. + Add "configure system hostname ." option to not use a FQDN for system name. + Add "-f json0" to provide a more regular/machine-parsable output to JSON output, even when not compiled with --enable-json0. * Fixes: + Handle team interfaces like a bond. Real MAC address cannot be retrieved yet. - Updates from lldpd (0.9.7) * Changes: + Attach remote TTL to port instead of chassis. + JSON support is now built-in and unconditionally enabled. Use --enable-json0 to keep the pre-0.9.2 json-c format. + When logging to syslog and daemonizing, don't log to stderr. + vxlan interfaces are now ignored as they are multi-point interfaces. + Maximum number of neighbors for an interface is increased from 4 to 32. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/lldpd/files/src-daemon-lldpd.service.in-Use-fixed-path-for-mkdir.patch32
-rw-r--r--meta-networking/recipes-daemons/lldpd/lldpd_0.9.8.bb (renamed from meta-networking/recipes-daemons/lldpd/lldpd_0.9.6.bb)6
2 files changed, 35 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/lldpd/files/src-daemon-lldpd.service.in-Use-fixed-path-for-mkdir.patch b/meta-networking/recipes-daemons/lldpd/files/src-daemon-lldpd.service.in-Use-fixed-path-for-mkdir.patch
new file mode 100644
index 0000000000..4876e17945
--- /dev/null
+++ b/meta-networking/recipes-daemons/lldpd/files/src-daemon-lldpd.service.in-Use-fixed-path-for-mkdir.patch
@@ -0,0 +1,32 @@
+From f9f3e4dd31588cce5f655730da7b5c3f56a9bdc1 Mon Sep 17 00:00:00 2001
+From: Fabio Berton <fabio.berton@ossystems.com.br>
+Date: Tue, 26 Sep 2017 09:19:51 -0300
+Subject: [PATCH] src/daemon/lldpd.service.in: Use fixed path for mkdir command
+Organization: O.S. Systems Software LTDA.
+
+@mkdir_p@ is expanded to host tools path ../build/tmp/hosttools/mkdir that
+doesn't exist on target. Remove @mkdir_p@ and use /bin/mkdir -p to
+create /var/run/lldpd directory.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
+---
+ src/daemon/lldpd.service.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/daemon/lldpd.service.in b/src/daemon/lldpd.service.in
+index fdb7338..4291830 100644
+--- a/src/daemon/lldpd.service.in
++++ b/src/daemon/lldpd.service.in
+@@ -9,7 +9,7 @@ Type=notify
+ NotifyAccess=main
+ EnvironmentFile=-/etc/default/lldpd
+ EnvironmentFile=-/etc/sysconfig/lldpd
+-ExecStartPre=@mkdir_p@ @PRIVSEP_CHROOT@
++ExecStartPre=/bin/mkdir -p @PRIVSEP_CHROOT@
+ ExecStart=@sbindir@/lldpd $DAEMON_ARGS $LLDPD_OPTIONS
+ Restart=on-failure
+ PrivateTmp=yes
+--
+2.14.2
diff --git a/meta-networking/recipes-daemons/lldpd/lldpd_0.9.6.bb b/meta-networking/recipes-daemons/lldpd/lldpd_0.9.8.bb
index 0cd0637201..dbd84cf673 100644
--- a/meta-networking/recipes-daemons/lldpd/lldpd_0.9.6.bb
+++ b/meta-networking/recipes-daemons/lldpd/lldpd_0.9.8.bb
@@ -9,10 +9,11 @@ SRC_URI = "\
http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
file://lldpd.init.d \
file://lldpd.default \
+ file://src-daemon-lldpd.service.in-Use-fixed-path-for-mkdir.patch \
"
-SRC_URI[md5sum] = "0dcdee7c1b3c62362d73f6508c11edae"
-SRC_URI[sha256sum] = "e74e2dd7e2a233ca1ff385c925ddae2a916d302819d1433741407d2f8fb0ddd8"
+SRC_URI[md5sum] = "8809600492f6b73149eb19158e819c1f"
+SRC_URI[sha256sum] = "9ee494e91bc33938575b2c09b26188c486ef8eac6e2155d250c189cc4e988c4f"
inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
@@ -29,7 +30,6 @@ EXTRA_OECONF += "--without-embedded-libevent \
"
PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
-PACKAGECONFIG[json] = "--with-json,--without-json,jansson"
PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"