aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Wiehler <stefan.wiehler@missinglinkelectronics.com>2018-10-10 11:29:04 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-10 08:53:21 -0700
commit62d21c0ca2ec269bbfb96530e934544f328256f7 (patch)
tree146e8cd5dc1ab26635da19a6ffb04c8cfc0091b7
parent8e3db630d13d110387eeed08f789ab3b18a3920e (diff)
downloadmeta-openembedded-contrib-62d21c0ca2ec269bbfb96530e934544f328256f7.tar.gz
nvme-cli: add recipe
NVMe management command line interface. Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch33
-rw-r--r--meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb21
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch b/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch
new file mode 100644
index 0000000000..154e1401a3
--- /dev/null
+++ b/meta-oe/recipes-bsp/nvme-cli/files/0001-Makefile-fix-bash-completion-install-path.patch
@@ -0,0 +1,33 @@
+From ef64032b34190079aab591c64a25f7535a977390 Mon Sep 17 00:00:00 2001
+From: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>
+Date: Tue, 9 Oct 2018 11:26:34 +0200
+Subject: [PATCH] Makefile: fix bash completion install path
+
+Change path to bash-completion upstream recommendation used by most
+distributions.
+
+Upstream-Status: Accepted
+
+Signed-off-by: Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index fa587dd..433bc41 100644
+--- a/Makefile
++++ b/Makefile
+@@ -69,8 +69,8 @@ install-bin: default
+ $(INSTALL) -m 755 nvme $(DESTDIR)$(SBINDIR)
+
+ install-bash-completion:
+- $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/bash_completion.d
+- $(INSTALL) -m 644 -T ./completions/bash-nvme-completion.sh $(DESTDIR)$(PREFIX)/share/bash_completion.d/nvme
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/share/bash-completion/completions
++ $(INSTALL) -m 644 -T ./completions/bash-nvme-completion.sh $(DESTDIR)$(PREFIX)/share/bash-completion/completions/nvme
+
+ install: install-bin install-man install-bash-completion
+
+--
+1.9.1
+
diff --git a/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb
new file mode 100644
index 0000000000..9b7e6cd4de
--- /dev/null
+++ b/meta-oe/recipes-bsp/nvme-cli/nvme-cli_1.6.bb
@@ -0,0 +1,21 @@
+SUMMARY = "NVMe management command line interface"
+AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
+HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
+DEPENDS = "util-linux"
+PV .= "+git${SRCPV}"
+
+SRC_URI = "git://github.com/linux-nvme/nvme-cli.git \
+ file://0001-Makefile-fix-bash-completion-install-path.patch \
+ "
+SRCREV = "642d426faf8a67ed01e90f7c35c0d967f8cc52a3"
+
+S = "${WORKDIR}/git"
+
+inherit bash-completion
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}