aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2018-05-16 16:55:14 -0400
committerKhem Raj <raj.khem@gmail.com>2018-05-23 15:32:05 -0700
commit46424e8d3e1565dac45307f5b91e7f2ab237a6e6 (patch)
treef44d270e7b01dbf9f12ea0c844c85c893c8579f3
parentcb7b35a4f9f93ecddbb245e32982d3674cef334d (diff)
downloadmeta-openembedded-contrib-46424e8d3e1565dac45307f5b91e7f2ab237a6e6.tar.gz
grpc: switch away from github archive
Since we know that github archives which are automatically generated have a tendency to change their checksums[1], switch to using a git clone. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-devtools/grpc/grpc_1.8.5.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-networking/recipes-devtools/grpc/grpc_1.8.5.bb b/meta-networking/recipes-devtools/grpc/grpc_1.8.5.bb
index 0883ec176b..a0c943d114 100644
--- a/meta-networking/recipes-devtools/grpc/grpc_1.8.5.bb
+++ b/meta-networking/recipes-devtools/grpc/grpc_1.8.5.bb
@@ -10,13 +10,13 @@ DEPENDS_append_class-target = " gtest grpc-native "
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRC_URI = "https://github.com/grpc/grpc/archive/v${PV}.tar.gz \
+S = "${WORKDIR}/git"
+SRCREV = "db68cb3652cc7697647e9934b5316d98a6ba04d1"
+BRANCH = "v1.8.x"
+SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;branch=${BRANCH} \
file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \
file://0004-CMakeLists.txt-Find-c-ares-in-target-sysroot-alone.patch \
"
-SRC_URI[md5sum] = "b565fa6787e42f4969395870c2ad436e"
-SRC_URI[sha256sum] = "df9168da760fd2ee970c74c9d1b63377e0024be248deaa844e784d0df47599de"
-
SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
inherit cmake