aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-22 21:59:20 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-26 21:10:55 -0700
commit8b7834aba887c67bd2d01e94b2e867578e691a3f (patch)
tree7bc1a2d3565782a2eb1df7586ee3a76155c27468
parenta44e42081db77c6cfd039cb8ea2be39399c6f4a3 (diff)
downloadmeta-openembedded-contrib-8b7834aba887c67bd2d01e94b2e867578e691a3f.tar.gz
procmail: Use build ldflags when invoking native compile/link
Some older compilers do not support security flags like -fstack-protector=strong and if we do not set this then it will use the target flags to pass here which will fail with gcc < 5.x, especially a problem building distros with security flags on host with 4.x gcc e.g. ubuntu 14.04 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/procmail/procmail_3.22.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/procmail/procmail_3.22.bb b/meta-oe/recipes-support/procmail/procmail_3.22.bb
index aa474ceb14..6160733b3d 100644
--- a/meta-oe/recipes-support/procmail/procmail_3.22.bb
+++ b/meta-oe/recipes-support/procmail/procmail_3.22.bb
@@ -29,7 +29,7 @@ do_configure() {
export CFLAGS="${BUILD_CFLAGS}"
export AR="${BUILD_AR}"
export AS="${BUILD_AS}"
- make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}" autoconf.h
+ make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${BUILD_LDFLAGS}" autoconf.h
}
do_compile() {