aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-17 23:45:51 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-23 15:32:05 -0700
commitcfa7834dbce48bdb243abd0635e2595ec422828b (patch)
tree5d3195ebe75dd170ddb5510c9aa379675f9b9b32
parentf604119524d970f500fecd0fd698b1c40f81f72f (diff)
downloadmeta-openembedded-contrib-cfa7834dbce48bdb243abd0635e2595ec422828b.tar.gz
stm32flash: Fix packaging errors
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/stm32flash/stm32flash_0.5.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/stm32flash/stm32flash_0.5.bb b/meta-oe/recipes-support/stm32flash/stm32flash_0.5.bb
index d401981ff9..854df06cb7 100644
--- a/meta-oe/recipes-support/stm32flash/stm32flash_0.5.bb
+++ b/meta-oe/recipes-support/stm32flash/stm32flash_0.5.bb
@@ -1,16 +1,16 @@
SUMMARY = "Open source flash program for STM32 using the ST serial bootloader"
HOMEPAGE = "https://sourceforge.net/projects/stm32flash/"
BUGTRACKER = "https://sourceforge.net/p/stm32flash/tickets/"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-inherit autotools-brokensep
+S = "${WORKDIR}/${BPN}"
-S = "${WORKDIR}/${PN}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
-SRC_URI = "https://prdownloads.sourceforge.net/stm32flash/stm32flash-${PV}.tar.gz"
+do_install() {
+ oe_runmake install DESTDIR=${D} PREFIX=${prefix}
+}
SRC_URI[md5sum] = "40f673502949f3bb655d2bcc539d7b6a"
SRC_URI[sha256sum] = "97aa9422ef02e82f7da9039329e21a437decf972cb3919ad817f70ac9a49e306"
-
-FILES_${PN} = "/usr/local/bin/stm32flash"