aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2019-10-04 14:40:26 +0300
committerKhem Raj <raj.khem@gmail.com>2019-10-04 19:11:55 -0700
commita4412258ef94d76f67db1e96d54a12c69e533bff (patch)
tree2bc2d79d9d28ffd9d210a86fe99e4d534024b573
parentb08e503eb75f1e6fee65cea4c03d18ad91e7a217 (diff)
downloadmeta-openembedded-contrib-a4412258ef94d76f67db1e96d54a12c69e533bff.tar.gz
renderdoc: add x11 to REQUIRED_DISTRO_FEATURES
This recipe depends on having x11 enabled so we add it to fix: ERROR: Nothing PROVIDES 'libxcb' (but meta-oe/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb DEPENDS on or otherwise requires it) libxcb was skipped: missing required distro feature 'x11' (not in DISTRO_FEATURES) Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
index b6e0c92f6d..c7e872409f 100644
--- a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
+++ b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
@@ -14,7 +14,9 @@ DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
-inherit cmake python3native
+inherit cmake python3native distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
python __anonymous () {
# only works on glibc systems